Hello community,

here is the log from the commit of package gnome-desktop for openSUSE:Factory 
checked in at 2016-09-21 18:38:18
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/gnome-desktop (Old)
 and      /work/SRC/openSUSE:Factory/.gnome-desktop.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "gnome-desktop"

Changes:
--------
--- /work/SRC/openSUSE:Factory/gnome-desktop/gnome-desktop.changes      
2016-08-17 12:02:35.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-desktop.new/gnome-desktop.changes 
2016-09-21 18:38:19.000000000 +0200
@@ -1,0 +2,45 @@
+Mon Sep 19 19:27:01 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.22.0:
+  + No changes, pure versionbump.
+
+-------------------------------------------------------------------
+Tue Sep 13 16:21:25 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.92:
+  + Fix a crash on non-udev platforms (bgo#770686).
+  + Updated translations.
+
+-------------------------------------------------------------------
+Tue Aug 16 18:49:35 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.90:
+  + No changes, pure versionbump.
+
+-------------------------------------------------------------------
+Sat Jul 23 20:18:16 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.4:
+  + Use udev's hwdb to query PNP IDs (--disable-udev to disable
+    this).
+  + Remove dependencies on xrandr and xext.
+- Following upstream changes, remove pkgconfig(xext) and
+  pkgconfig(xrandr) and add pkgconfig(libudev) BuildRequires.
+- Drop gnome-desktop-bnc896687-benq-pnp-id.patch: Not needed
+  anymore since the switch to udev's hwdb.
+
+-------------------------------------------------------------------
+Tue Jun 21 19:52:08 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.3:
+  + Updated translations.
+- Drop gnome-about obsoletes: gnome-about have not been around
+  since before GNOME 3.0, it's about time we drop it.
+
+-------------------------------------------------------------------
+Sat May 28 21:34:15 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.2:
+  + Add API to know if a GnomeRRMode is interlaced.
+
+-------------------------------------------------------------------

Old:
----
  gnome-desktop-3.20.2.tar.xz
  gnome-desktop-bnc896687-benq-pnp-id.patch

New:
----
  gnome-desktop-3.22.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gnome-desktop.spec ++++++
--- /var/tmp/diff_new_pack.pmh1fM/_old  2016-09-21 18:38:21.000000000 +0200
+++ /var/tmp/diff_new_pack.pmh1fM/_new  2016-09-21 18:38:21.000000000 +0200
@@ -19,16 +19,14 @@
 %define IS_DEFAULT_GNOME_DESKTOP 1
 
 Name:           gnome-desktop
-Version:        3.20.2
+Version:        3.22.0
 Release:        0
 Summary:        The GNOME Desktop API Library
 License:        LGPL-2.1+
 Group:          System/GUI/GNOME
 Url:            http://www.gnome.org
-Source:         
http://download.gnome.org/sources/gnome-desktop/3.20/%{name}-%{version}.tar.xz
+Source:         
http://download.gnome.org/sources/gnome-desktop/3.22/%{name}-%{version}.tar.xz
 Source99:       baselibs.conf
-# PATCH-FIX-UPSTREAM gnome-desktop-bnc896687-benq-pnp-id.patch bsc#896687 
bgo#748914 feder...@suse.com -- Add identifier for BenQ displays
-Patch1:         gnome-desktop-bnc896687-benq-pnp-id.patch
 BuildRequires:  fdupes
 BuildRequires:  gobject-introspection-devel
 BuildRequires:  intltool
@@ -39,11 +37,10 @@
 BuildRequires:  pkgconfig(gsettings-desktop-schemas) >= 3.5.91
 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.3.6
 BuildRequires:  pkgconfig(iso-codes)
+BuildRequires:  pkgconfig(libudev)
 BuildRequires:  pkgconfig(x11)
-BuildRequires:  pkgconfig(xext) >= 1.1
 BuildRequires:  pkgconfig(xkbfile)
 BuildRequires:  pkgconfig(xkeyboard-config)
-BuildRequires:  pkgconfig(xrandr) >= 1.3
 %if 0%{?BUILD_FROM_VCS}
 BuildRequires:  gnome-common
 BuildRequires:  gtk-doc
@@ -58,9 +55,6 @@
 %package -n gnome-version
 Summary:        GNOME version
 Group:          System/GUI/GNOME
-%if %IS_DEFAULT_GNOME_DESKTOP
-Obsoletes:      gnome-about < %{version}
-%endif
 
 %description -n gnome-version
 This package contains information on the version of GNOME that is installed.
@@ -128,7 +122,6 @@
 %lang_package
 %prep
 %setup -q
-%patch1 -p1
 translation-update-upstream
 
 %if 0%{?BUILD_FROM_VCS}
@@ -174,7 +167,6 @@
 %doc %{_datadir}/help/C/fdl/
 %doc %{_datadir}/help/C/gpl/
 %doc %{_datadir}/help/C/lgpl/
-%{_datadir}/libgnome-desktop-3.0/
 %{_libexecdir}/gnome-rr-debug
 
 %files -n typelib-1_0-GnomeDesktop-3_0

++++++ gnome-desktop-3.20.2.tar.xz -> gnome-desktop-3.22.0.tar.xz ++++++
++++ 8249 lines of diff (skipped)


Reply via email to