Hello community,

here is the log from the commit of package gnome-calculator for 
openSUSE:Factory checked in at 2016-09-21 18:38:52
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/gnome-calculator (Old)
 and      /work/SRC/openSUSE:Factory/.gnome-calculator.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "gnome-calculator"

Changes:
--------
--- /work/SRC/openSUSE:Factory/gnome-calculator/gnome-calculator.changes        
2016-08-24 10:07:05.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-calculator.new/gnome-calculator.changes   
2016-09-21 18:38:54.000000000 +0200
@@ -1,0 +2,39 @@
+Mon Sep 19 20:02:16 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.22.0:
+  + Fix base change for log, fixes bgo#748729.
+  + Math buttons: fix a (potential) crash loading financial
+    dialogs.
+  + Updated translations.
+
+-------------------------------------------------------------------
+Mon Sep 12 19:16:59 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.92:
+  + Fix the build.
+  + Updated translations.
+
+-------------------------------------------------------------------
+Sat Aug 20 11:18:38 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.90:
+  + Added 'period' keypress when the delete key on the numpad is
+    pressed.
+  + lib: prevents segfault when elements of division to zero have
+    null assigned tokens (bgo#769364).
+  + Add Language headers to po files.
+  + Updated translations.
+
+-------------------------------------------------------------------
+Sat Aug 20 11:18:37 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.21.2:
+  + Distribute history-view.ui and history-entry.ui.
+  + Updated translations.
+- Drop gcalctool and gcalctool-lang Obsoletes: Removed since 3.8.0
+  release, there is no openSUSE release with GNOME that old.
+- Conditionally apply translations-update-upstream BuildRequires
+  and macro for non-openSUSE only.
+- Drop history-entry.ui and history-view.ui: No longer missing.
+
+-------------------------------------------------------------------

Old:
----
  gnome-calculator-3.20.2.tar.xz
  history-entry.ui
  history-view.ui

New:
----
  gnome-calculator-3.22.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gnome-calculator.spec ++++++
--- /var/tmp/diff_new_pack.LgeIve/_old  2016-09-21 18:38:55.000000000 +0200
+++ /var/tmp/diff_new_pack.LgeIve/_new  2016-09-21 18:38:55.000000000 +0200
@@ -17,20 +17,19 @@
 
 
 Name:           gnome-calculator
-Version:        3.20.2
+Version:        3.22.0
 Release:        0
 Summary:        A GNOME Calculator Application
 License:        GPL-3.0+
 Group:          Productivity/Scientific/Math
 Url:            http://www.gnome.org
-Source:         
http://download.gnome.org/sources/gnome-calculator/3.20/%{name}-%{version}.tar.xz
-# Source files that were missing in the tarball
-Source1:        history-entry.ui
-Source2:        history-view.ui
+Source:         
http://download.gnome.org/sources/gnome-calculator/3.22/%{name}-%{version}.tar.xz
 BuildRequires:  fdupes
 BuildRequires:  intltool >= 0.50
 BuildRequires:  mpfr-devel
+%if !0%{?is_opensuse}
 BuildRequires:  translation-update-upstream
+%endif
 BuildRequires:  update-desktop-files
 BuildRequires:  yelp-tools
 BuildRequires:  pkgconfig(gio-2.0) >= 2.40
@@ -40,11 +39,6 @@
 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.42
 BuildRequires:  pkgconfig(libxml-2.0)
 Recommends:     %{name}-lang
-# gcactool was renamed to gnome-calculator. Last known version was 6.6.2
-Obsoletes:      gcalctool <= 6.6.2
-# gcalctool-lang package should be obsoleted, obviously by the -lang package, 
but that's not possible.
-# So for an easy upgrade path, we obsolete it in the main package.
-Obsoletes:      gcalctool-lang <= 6.6.2
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 %glib2_gsettings_schema_requires
 
@@ -64,8 +58,9 @@
 %lang_package
 %prep
 %setup -q
-cp %{S:1} %{S:2} data/
+%if !0%{?is_opensuse}
 translation-update-upstream
+%endif
 
 %build
 %configure \

++++++ gnome-calculator-3.20.2.tar.xz -> gnome-calculator-3.22.0.tar.xz ++++++
++++ 24197 lines of diff (skipped)


Reply via email to