Hi, in most C libraries it's good practice to use a common prefix for all functions to avoid name clashes with other libraries. libopenvas doesn't follow that convention yet. Some of the functions use "nessus_" as prefix, some groups of related functions have a common prefix (e.g. "arg_" or "plug_") and some don't have any such prefix.
I'm about to introduce some new functions into libopenvas and I don't want to add functions without a prefix. Using "nessus_" doesn't seem like a good option, though. Therefore, I propose to use "ovs_" as the prefix for all new functions. If we change the signature of existing functions, we should use the opportunity to rename the function to use the "ovs_" prefix, too. What do you think? In the long run we may have to think about what to do with other existing functions, but since libopenvas is only used by OpenVAS it's not very important to change anything about the old functions. Bernhard
pgpTyuw1BhVD2.pgp
Description: PGP signature
_______________________________________________ Openvas-devel mailing list [email protected] http://lists.wald.intevation.org/mailman/listinfo/openvas-devel
