Hi, On Fri, Sep 05, 2014 at 05:25:29PM +0200, dav...@redhat.com wrote: > return (lstat("/sys/fs/cgroup", &a) == 0) > - && (lstat("/sys/fs/cgroup/systemd", &b) == 0) > - && (a.st_dev != b.st_dev); > - > + && (lstat("/sys/fs/cgroup/systemd", &b) == 0) > + && (stat(SYSTEMD_ASK_PASSWORD_PATH, &c) == 0) > + && (a.st_dev != b.st_dev);
ACK on the code, NAK on the indent change. The old code had tabs there, the new one has spaces - and not enough of them anyway. For clarity, you might want to keep the "a.st_dev != b.st_dev" comparison befor the stat() on SYSTEMD_ASK_PASSWORD_PATH, as the comparison belongs to the /sys/fs/... stuff, not to the third stat(). gert -- USENET is *not* the non-clickable part of WWW! //www.muc.de/~gert/ Gert Doering - Munich, Germany g...@greenie.muc.de fax: +49-89-35655025 g...@net.informatik.tu-muenchen.de
pgpZa_gXFWhQy.pgp
Description: PGP signature