Hi,

On Tue, Jan 30, 2018 at 4:33 AM, Samuli Seppänen <sam...@openvpn.net> wrote:
> Hi,
>
> Il 29/01/2018 20:09, Selva Nair ha scritto:
>> (Cross posting to users and devel)
>>
>> Hi,
>>
>> 2.4.x needs to support, Vista, isn't it?
>
> Good question and we have discussed in the past. Windows Vista is no
> longer supported by Microsoft:
>
> <https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet>
>
> But then again, we do provide installers which work on Windows XP, which
> is similarly EOL. So I guess we do support Windows Vista for the time being.
>
>>
>> Can anyone please latest 2.4 release branch on Windows Vista using an
>> RSA certificate in Windows cert store (using --cryptoapicert option) ?
>>
>> Need to be built with openssl 1.1. Not sure the snapshots are built that 
>> way..
>> https://build.openvpn.net/downloads/snapshots/
>
> Not yet. I will switch snapshot builds to OpenSSL 1.1 once
> openvpn-build's openvpn.nsi stops failing on OpenSSL 1.1 libraries
> (names have changed). A PR is pending but it still needs one minor fix.
>
>> The recent changes to cryptoapi uses CNG api which is supposedly
>> supported on Vista but some testing would be useful. I no longer have
>> access to a Vista machine.

FWIW, I did quick test of master (with openssl 1.1) on Windows server
2008 (API version same as vista?). Using cryptoapicert with an EC cert
worked, so hopefully its all good.

By the way, 2.4 with openssl 1.0 and 1.1 should have the same
functionality. Thus testing the current snapshot build (openssl 1.0)
is useful too..

Selva

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel

Reply via email to