The actual retrieval of the MAC address in mtd_get_mac_binary_ubi()
is the same as in get_mac_binary(). Thus, use the latter function
in the former to reduce duplicate code.

This will also allow to benefit from the enhanced path check there
and bring mtd_get_mac_binary_ubi() more in line with the similar
mtd_get_mac_binary().

Signed-off-by: Adrian Schmutzler <freif...@adrianschmutzler.de>
(cherry picked from commit 45600124fcbd14ece6e289cb59b318ea44c598fe)

---

The enhanced path check in get_mac_binary has been backported a while
ago. Enable mtd_get_mac_binary_ubi to use it also on 19.07.
---
 package/base-files/files/lib/functions/system.sh | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

diff --git a/package/base-files/files/lib/functions/system.sh 
b/package/base-files/files/lib/functions/system.sh
index 9b9d03df7b..dceb66a851 100644
--- a/package/base-files/files/lib/functions/system.sh
+++ b/package/base-files/files/lib/functions/system.sh
@@ -79,12 +79,7 @@ mtd_get_mac_binary_ubi() {
        local ubidev=$(nand_find_ubi $CI_UBIPART)
        local part=$(nand_find_volume $ubidev $1)
 
-       if [ -z "$part" ]; then
-               echo "mtd_get_mac_binary: ubi volume $mtdname not found!" >&2
-               return
-       fi
-
-       hexdump -v -n 6 -s $offset -e '5/1 "%02x:" 1/1 "%02x"' /dev/$part 
2>/dev/null
+       get_mac_binary "/dev/$part" "$offset"
 }
 
 mtd_get_part_size() {
-- 
2.20.1


_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel

Reply via email to