I have never tried the specific combination.I will however suggest you to check wheter 
the orion specific jars are in the IPlanet server classpath.


-----Original Message-----
From: Grum Ketema [mailto:[EMAIL PROTECTED]]
Sent: Wednesday, April 24, 2002 10:39 PM
To: Orion-Interest
Subject: RE: Accessing an EJB in Orion App server from a servlet in


I have tried several times with different options
1. If I try
        Object homeObject = ctx.lookup("java:comp/env/fred/fredBean");
                instead of
        Object homeObject = ctx.lookup("fred/fredBean");
        I get NameNotFound exception which makes sense since I am doing a name look
        not EJB reference lookup -
2. Occasionally I get the exception Connection broken by the peer exception
and other times
        I get exception that says the protocol used is not ORMI
3. For the most part it hangs

Has anybody tried Orion with Iplanet

-----Original Message-----
[mailto:[EMAIL PROTECTED]]On Behalf Of sbpodila
Sent: Wednesday, April 24, 2002 12:20 AM
To: Orion-Interest
Subject: Re: Accessing an EJB in Orion App server from a servlet in

Did you got any error or exception while trying to access the bean?I think
you may get a security related exception


----- Original Message -----
From: "Grum Ketema" <[EMAIL PROTECTED]>
To: "Orion-Interest" <[EMAIL PROTECTED]>
Sent: Wednesday, April 24, 2002 6:54 AM
Subject: Accessing an EJB in Orion App server from a servlet in Iplanet

> Hello,
> I have been trying to access an EJB deployed in Orion app server from a
> servlet deployed in Iplanet. I have
> the following code in the servlet
> Hashtable env = new Hashtable();
> "com.evermind.server.rmi.RMIInitialContextFactory");
> env.put(Context.PROVIDER_URL, "ormi://nap1/fredWeb");
> env.put(Context.SECURITY_PRINCIPAL, "admin");
> env.put(Context.SECURITY_CREDENTIALS, "xyz");
> Context ctx = new InitialContext(env);
> Object homeObject = ctx.lookup("fred/fredBean");
> The ctx.lookup() call hangs for ever. If I replace
> Object homeObject = ctx.lookup("fred/fredBean");
> With this same code I can access the bean from a stand alone client.
> I have been struggling with this for a few days and nothing seems to work.
> All suggestions are appreciated
> Regards,
> Grum

Reply via email to