I just moved to orion1.5.4 and it seems that orion is treating my orion
specific orion-ejb-jar.xml properties differently.  I am using an Oracle
8i database and the only table I am concerned with are in the yc_content
schema but when I set up my orion-ejb-jar.xml file to point to the
table="yc_content.employee" it creates a new table in my database under
system.yc_content_employee. It appears to be ignoring my '.' and
replacing it with an '_' and creating my table in the system schema.  I
am using a username of system so that I can see the entire database but
even when I try using a username of yc_content so that I can only see
the yc_content tables I get a somewhat similar error.  If I specify the
table name as "yc_content.employee" the console says that it deploys the
ejb  i.e.-"deploying 'crm_reports.Employee' ... done" but no new
directory for my ejb is created in the application-deployments
directory, and if I use a table name of 'employee' with my yc_content
username I get the error 'yc_content_data has reached it's maximum
limit' and does not create a table or deploy any beans.  The funny thing
is that I was able to get this to work in 1.5.3 using the system
username and setting the table name to 'yc_content.employee' and orion
attempted to create the table but found that it already existed and used
the preexisting table instead, and everything worked like a champ.  Any
ideas about what could be going on.

P.S.- I tried using the EJB2.0 spec deployment descriptor and putting
'yc_content' for the abstract-schema property in the entity deployment
descriptors but I am not all that familiar with EJB2.0 yet and am not
sure what this property is supposed to be, but orion will not let me
deploy any EJB2.0 beans without this property being set.

Tim Pouyer

Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

Reply via email to