Hi Marco,

I agree. This definitely looks like a bug. But it might be related to particular card. I tried today Vista x64 with 178.24 on GeForce 280 GTX. Everything was ok. Both osgviewer and my example ran fine.

Cheers,
Wojtek

Hi Wojtek,

your test case behaves exactly as osgViewer does. The app crashes when wglMakeCurrent() gets called for the second time. Setting repeatMakeCurrent to 0 fixes the crash. One thing I forgot to say, is that it doesn't always crash: the success/failure ratio is about 1 to 15. This applies to both osgViewer and your test program. Also, it seems that forcing the "multithreaded optimization" option to "enabled" in the nVIDIA Control Panel (it defaulted to "automatic" in my driver) makes things work. I still consider this a driver bug, however, because leaving an optional optimization to its default value should never crash applications.

Marco


--------------------------------------------------
From: "Wojciech Lewandowski" <[EMAIL PROTECTED]>
Sent: Wednesday, November 12, 2008 11:42 AM
To: <osg-users@lists.openscenegraph.org>
Subject: Re: [osg-users] crash with"multimonitormultithreadnVIDIAworkaround" enabled

Hi Marco,

Here it is. My server does not like sending exectuables. I hope You don't
mind VS 9.0 source & solution.

Example is as simple as multithreaded opengl example can be. WindowOGL class
does initlaization in one thread and rendering in the other thread. Its
repeatMakeCurrent variable is set to 1 by default which means that each
makeCurrentContext will be repeated once.  So if everything goes exactly
like with osgViewer it should the crash there. If you find that example
works, try runing with repeatMakeCurrent set to 0 and check if the screen is
all green (does not display red triangle). Red triangle would mean that
drivers have remained broken.

Thanks a lot.
Wojtek Lewandowski


Thanks, Marco.

I will send this code tomorrow from my office. I don't have it at home.

Cheers,
Wojtek

Hi Wojtek,

Its really weird. I am pretty much sure we have tested this with Vista
x64,
but maybe not the latest drivers. May I send you simpified OpenGL only
repro
I have sent to NVidia as a bug report ? I am curious if the crash will
happen with it as well ?

Sure, I'm glad to help.

Marco


_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to