Paul,
 
I tried to do setAttribute( m_pPolygonOffset, osg::StateAttribute::OFF
); but I suppose your code may still be able to detect that the
attribute is present. I forgot there was a removeAttribute. Do you think
it's worth a shot for me to code it up and try again? 
 
Thanks!
John

________________________________

From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of Paul
Martz
Sent: Wednesday, November 12, 2008 1:08 PM
To: 'OpenSceneGraph Users'
Subject: Re: [osg-users] BUG FOUND: FLT Writer Duplicate Node Names?


John -- Use of polygon offset controls whether the exporter uses
subfaces or not. It might be the case that the subface code has some
kind of problem with texture mapping.
 
One thing you can try is to go into expGeometryRecords.cpp and disable
use of subfaces by commenting out the SubfaceHelper instances at lines
934 and 1023. This will cause incorrect rendering of coplanar polygons,
of course, but if it changes the behavior of your texture mapping issue,
then this is a good indication of where the problem lies.
 
Let me know how it goes.
   -Paul
 


________________________________

        From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of
Argentieri, John-P63223
        Sent: Tuesday, November 11, 2008 11:35 AM
        To: [EMAIL PROTECTED]
        Subject: Re: [osg-users] BUG FOUND: FLT Writer Duplicate Node
Names?
        
        
        Paul,
         
        Attached is an example of a bug I found in the FLT writer. If
the GL_POLYGON_OFFSET remains inside of extref.osg, then converting it
to FLT using osgconv will cause the texture of the external reference to
disappear. If the GL_POLYGON_OFFSET is removed from extref.osg, then
extref.osg is converted to FLT using osgconv, the texture on the
external reference remains.
         
        Thanks,
        John Argentieri

________________________________

        From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of
Argentieri, John-P63223
        Sent: Tuesday, November 11, 2008 12:29 PM
        To: [EMAIL PROTECTED]
        Subject: Re: [osg-users] FLT Writer Duplicate Node Names?
        
        
        Guys,
         
        Has anyone used the ProxyNode in this way, in OpenFlight files?
My primary file and my externally referenced file are both OpenFlight
files. The externally referenced file gets loaded, but the texture is
incorrect. The texture applied to the model, in my case, is the only one
that is used internally in the primary OpenFlight file. For example, my
terrain surface is internal and textured as grass. My externally
reference tree models are shaped like trees, but also textured in grass.
I've tried moving the tree's texture files around to be sure that it
wasn't a path issue. It didn't work.
         
        Is there anyone that can help me to resolve the issues I am
having? All I want to do is write an OpenFlight file that contains
several clones of another OpenFlight file. The straightforward approach
breaks -- not for the current OSG loader, but for other loaders that
expect node names to be unique.
         
        Your friend,
        John Argentieri
         
________________________________

        From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of Paul
Martz
        Sent: Friday, November 07, 2008 1:51 PM
        To: 'OpenSceneGraph Users'
        Subject: Re: [osg-users] FLT Writer Duplicate Node Names?
        
        
        The exporter writes an external reference record when it
encounters a ProxyNode. The importer should do the inverse operation.
         
        I searched for the error text you mentioned, but could not find
any code in OSG that displays that error, so I can't really help you
with that.
           -Paul
         


________________________________

                From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of
Argentieri, John-P63223
                Sent: Friday, November 07, 2008 11:42 AM
                To: [EMAIL PROTECTED]
                Subject: Re: [osg-users] FLT Writer Duplicate Node
Names?
                
                
                Paul,
                 
                Is there a way that I can place multiple instances of an
external .flt file into another .flt file? I'm trying to use ProxyNode,
but still getting these errors:
                 
                Non primary record found as child. op=19
                Non primary record found as child. op=19
                Non primary record found as child. op=20
                Non primary record found as child. op=20
                 
                Thanks,
                John
                 

________________________________

                From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of Paul
Martz
                Sent: Friday, November 07, 2008 12:51 PM
                To: 'OpenSceneGraph Users'
                Subject: Re: [osg-users] FLT Writer Duplicate Node
Names?
                
                
                The exporter dumps the Node name to the FLT record name,
just as the importer does the inverse operation. I don't believe there
is any code to check for and avoid duplicate node names.
                 
                I'd think it would be up to the application to specify
unique Node names, as the exporter has no other way to know what text
should be written to the FLT record name. I can see how it might be
useful to have a "I don't care what you name it, just make sure it's
unique" mode. Currently, this doesn't exist. You are welcome to add it.
                   -Paul
                 


________________________________

                        From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] On Behalf Of
Argentieri, John-P63223
                        Sent: Friday, November 07, 2008 8:41 AM
                        To: [EMAIL PROTECTED]
                        Subject: [osg-users] FLT Writer Duplicate Node
Names?
                        
                        
                        Hello all.
                         
                        Does the FLT writer create duplicate node names
for nodes with multiple transforms as parents? We're having trouble
sharing a single model inside of multiple transforms scattered about.
Some older OpenFlight software we are interfacing to does not like this.
Any thoughts guys?
                         
                        Thank you,
                        John Argentieri 
                        Software Engineer 
                        GENERAL DYNAMICS 
                        C4 Systems 
                        [EMAIL PROTECTED] 

                        "This email message is for the sole use of the
intended recipient(s) and may contain GDC4S confidential or privileged
information. Any unauthorized review, use, disclosure or distribution is
prohibited. If you are not an intended recipient, please contact the
sender by reply email and destroy all copies of the original message."

                         

_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to