#564: run eric6 python ide along with qgis3/qt5 error
------------------------------------+----------------------------
Reporter:  muellea                  |       Owner:  osgeo4w-dev@…
    Type:  defect                   |      Status:  closed
Priority:  major                    |   Component:  Package
 Version:                           |  Resolution:  worksforme
Keywords:  python3 pyqt5 ide eric6  |
------------------------------------+----------------------------

Comment (by muellea):

 Thank you jef,
 now i have QtWebEngineProcess.exe, it's in my path, but python/Qt doesn't
 find it. So it's quite the same.

 I do use this little python script for further testing. It tries to show a
 QWebEngineView.

 {{{
 import sys

 from PyQt5.QtWidgets import QApplication
 from PyQt5.QtWidgets import QMainWindow
 from PyQt5.QtWebEngineWidgets import QWebEngineView
 from PyQt5.QtCore import QUrl
 def main():
     app = QApplication(sys.argv)
     window = QMainWindow()
     window.setWindowTitle('PyQt Demo')
     window.setGeometry(320, 180, 960, 540)
     view = QWebEngineView()
     view.load(QUrl('http://leafletjs.com/')) # error here
     window.setCentralWidget(view)
     window.show()
     sys.exit(app.exec_())
 if __name__ == '__main__':
     main()
 }}}

 QT_PLUGIN_PATH ist set. When I also set QTWEBENGINEPROCESS_PATH to the
 correct path, the error isn't showing -  but then i got new ones:

 {{{
 Qt WebEngine ICU data not found at
 C:/src/Qt/Qt5.9.2-2/5.9.2/msvc2015/resources. Trying parent directory...
 Qt WebEngine ICU data not found at C:/src/Qt/Qt5.9.2-2/5.9.2/msvc2015.
 Trying application directory...
 Qt WebEngine ICU data not found at G:/tmp/q3/apps/Python36. Trying
 fallback directory... The application MAY NOT work.
 Installed Qt WebEngine locales directory not found at location
 C:/src/Qt/Qt5.9.2-2/5.9.2/msvc2015/translations\qtwebengine_locales.
 Trying application directory...
 Qt WebEngine locales directory not found at location
 G:/tmp/q3/apps/Python36\qtwebengine_locales. Trying fallback directory...
 Translations MAY NOT not be correct.
 [0313/220213.363:ERROR:icu_util.cc(178)] Invalid file descriptor to ICU
 data received.
 [0313/220213.370:FATAL:icu_util.cc(297)] Check failed: result.
 }}}

 It seems, qt has a wrong configuration, icudtl.dat is in
 G:\tmp\q3\apps\Qt5\resources, qtwebengine_locales is under
 G:\tmp\q3\apps\Qt5\translations. I used py3_env.bat and qt5_env.bat before
 execution.

 My path:
 {{{
 
PATH=G:\tmp\q3\apps\qt5\bin;G:\tmp\q3\apps\Python36;G:\tmp\q3\apps\Python36\Scripts;G:\tmp\q3\apps\qt5\bin;G:\tmp\q3\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\WBem;G:\tmp\q3\apps\Python36\Scripts;G:\tmp\q3\apps\qgis\bin
 }}}

 Some entries are doubled, as you can see...

-- 
Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/564#comment:2>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.
_______________________________________________
osgeo4w-dev mailing list
osgeo4w-dev@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/osgeo4w-dev

Reply via email to