As reported in Trac #5489 [0], osmosis uses Netty 3 which its upstream
stopped supporting in 2016. Osmosis needs to be ported to Netty 4.

The lack of security support for Netty 3 is reason for its removal from
the next Debian stable release. And unless osmosis is updated to use
Netty 4, it will also be removed (and by extension from Ubuntu which
syncs its packages from Debian).

I'd very much like to keep osmosis in Debian, but like FauxFaux do not
have the skills required to port osmosis to Netty 4.

Who does have the skills to port osmosis to Netty 4? If no developer has
time, would a crowfunding campaign help to fund development time?

[0] https://trac.openstreetmap.org/ticket/5489

Kind Regards,

Bas

_______________________________________________
osmosis-dev mailing list
osmosis-dev@openstreetmap.org
https://lists.openstreetmap.org/listinfo/osmosis-dev

Reply via email to