Sending this as a RFC because it is still not polished (especially on the structure layout side, in the last patch).
This series aims at splitting the netdev-dpdk.c file and the netdev_dpdk structure that intermix all the various concerns for "normal" (I call them ethernet) DPDK ports and vhost DPDK ports. Until the last patch, there should be no performance impact, but I did not go far enough to back that claim. My hope is to have this series in a good shape to ease integration of netdev-doca.c. Comments welcome. -- David Marchand David Marchand (11): netdev-dpdk: Hide some rte_flow error helper. netdev-dpdk: Cleanup netdev ops. netdev-dpdk: Separate ethernet and vhost netdev ops. netdev-dpdk: Insulate mempool creation from netdev_dpdk. netdev-dpdk: Separate ethernet and vhost specific fields. netdev-dpdk: Move common fields and associated helpers. netdev-dpdk: Move mempool code. netdev-dpdk: Move QoS code. netdev-dpdk: Move transmission code. netdev-dpdk: Store vhost ports in a separate list. netdev-dpdk: Split ethernet and vhost netdevs. lib/automake.mk | 4 +- lib/netdev-dpdk-common.c | 1789 +++++++++++++++++ lib/netdev-dpdk-common.h | 517 +++++ lib/netdev-dpdk.c | 4018 ++++++++++++-------------------------- lib/netdev-dpdk.h | 11 - tests/system-dpdk.at | 1 + 6 files changed, 3563 insertions(+), 2777 deletions(-) create mode 100644 lib/netdev-dpdk-common.c create mode 100644 lib/netdev-dpdk-common.h -- 2.54.0 _______________________________________________ dev mailing list [email protected] https://mail.openvswitch.org/mailman/listinfo/ovs-dev
