On 30 Jul 2026, at 19:49, Aaron Conole wrote: > Conntrack has a number of places where it would be useful to monitor > changes. Currently, these are hard coded spots for things like alg > handlers that need to fire when connections are added and transition > so that we can monitor packets. This leads to very difficult to read > code, with messy branches all over the place, and a bunch of unrelated > functions mixed together. > > Rename the conn_update_state_alg() function to conn_update_state_dist() > and abstract away the FTP specific hook logic. The original function > required manual modification to add additional handlers, which we want > to avoid and make more generic for future additions (which can include > observers for hardware offloads). The hooks are priority based so > that some high priority hooks can run early, while later hooks that > consume the event can run later. > > This infrastructure relies on the fact that there is only one global > conntrack instance. If the conntrack ever returns to allowing for > multiple instances, this will need to be re-abstracted. > > Assisted-by: Claude Sonnet 4.6 <[email protected]> > Signed-off-by: Aaron Conole <[email protected]>
Hi Aaron, This patch looks good to me. Only the priority order seems odd to me. Most OVS code uses lower value equals lower priority. I guess you try to mimic the kernel's priority scheme? Anyhow, Acked-by: Eelco Chaudron <[email protected]> _______________________________________________ dev mailing list [email protected] https://mail.openvswitch.org/mailman/listinfo/ovs-dev
