Wang Zhan wrote:
> On Mon, 28 Sep 2026 19:59:54 -0400 Willem de Bruijn wrote:
> > > + GSO_TEST_BOUNDED,
> > > + GSO_TEST_BOUNDED_MULTI,
> > > + GSO_TEST_BOUNDED_ONE_MSS,
> >
> > nit: bound is not a helpful name for this feature.
> >
> > The default segments to a stream of skbs of MSS 1, so segmenting to
> > a stream of skbs larger MSS to me is not bounding. Quite the opposite.
> >
> > Not a comment only about this test patch.
> >
> > Perhaps partial or re-segmentation better captures it.
>
> Agreed. I think re-segmentation is descriptive enough. Partial is
> already for NETIF_F_GSO_PARTIAL.
Come to think of it, that may have always been the intention of partial?
Segment, but not yet fully.
Technically this would more be pre-segment than resegment.
Anyway, I don't mean to bikeshed this and don't have a better name.
Either will do.
> > > + {
> > > + /*
> > > + * One MSS per skb is what the unbounded path produces, so a
> > > + * bound of a single segment must not change the output.
> > > + */
> >
> > so setting max_segs = 0 is equivalent to setting max_segs = 1.
>
> Right. The default is one MSS per skb, so 0 and 1 behave the same.
_______________________________________________
dev mailing list
[email protected]
https://mail.openvswitch.org/mailman/listinfo/ovs-dev