This series aims at splitting the netdev-dpdk.c file and the netdev_dpdk
structure that intermix all the various concerns for "normal"
(I call them ethernet) DPDK ports and vhost DPDK ports.

Besides the splitting of those ports types, one main goal is to have
saner locking and limit the amount of copy/pasting
when the netdev-doca.c lands, while limiting performance impact.

There is one more patch needed for netdev-doca.c but it did not make
sense alone, I'll reply in the DOCA thread instead.


-- 
David Marchand

Changes since RFC v1:
- fixed many coding style issues (comments, argument omission, ...),
- reworked locking in construct/destruct helpers, which cascaded in
  simplifying subsequent changes,
- fine tuned structure layout in last patch,

David Marchand (12):
  netdev-dpdk: Hide some rte_flow error helper.
  netdev-dpdk: Cleanup netdev ops.
  netdev-dpdk: Separate ethernet and vhost netdev ops.
  netdev-dpdk: Insulate mempool creation from netdev_dpdk.
  netdev-dpdk: Narrow global dpdk mutex scope.
  netdev-dpdk: Separate ethernet and vhost specific fields.
  netdev-dpdk: Move common fields and associated helpers.
  netdev-dpdk: Move mempool code.
  netdev-dpdk: Move QoS code.
  netdev-dpdk: Move transmission code.
  netdev-dpdk: Store vhost ports in a separate list.
  netdev-dpdk: Split ethernet and vhost netdevs.

 lib/automake.mk          |    4 +-
 lib/netdev-dpdk-common.c | 1798 +++++++++++++++++
 lib/netdev-dpdk-common.h |  509 +++++
 lib/netdev-dpdk.c        | 4035 ++++++++++++--------------------------
 lib/netdev-dpdk.h        |   11 -
 tests/system-dpdk.at     |    1 +
 6 files changed, 3563 insertions(+), 2795 deletions(-)
 create mode 100644 lib/netdev-dpdk-common.c
 create mode 100644 lib/netdev-dpdk-common.h

-- 
2.56.0

_______________________________________________
dev mailing list
[email protected]
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to