> Maybe I don't fully understand what you're trying to say, but I want to use
> unsafe function in dpif-netdev for per-flow packet batching (see the patch)
> and it should not be internal for that case.
> (It's safe to use unsafe function there because per-flow batches are
> guaranteed to be less than original rx batch.)
Let me try again. As you ave pointed out, it is not really unsafe to
use the function
at those calling sites, I think dp_packet_batch_add__() is a suitable
name. In case
you prefer a different function name, that's fine too, I just don't
think unsafe is accurate.
dev mailing list