DP_PACKET_BATCH_FOR_EACH macro was introduced early this year as part
of enhancing packet batch APIs. Commit '72c84bc2' implemented this macro
and replaced most of the calling sites with macros and simplified the logic.

However there are still many APIs that needs to be fixed.
This patch series is a simple and straightforward set of changes
aimed at using DP_PACKET_BATCH_FOR_EACH macro at all appropriate places.
Also minor code cleanup is done to improve readability of the code.

No functionality changes and no performance impact with this series.

Bhanuprakash Bodireddy (10):
  netdev-linux: Clean up netdev_linux_sock_batch_send().
  netdev-linux: Use DP_PACKET_BATCH_FOR_EACH in
    netdev_linux_tap_batch_send.
  netdev-dpdk: Cleanup dpdk_do_tx_copy.
  netdev-dpdk: Minor cleanup of netdev_dpdk_send__.
  netdev-dpdk: Use DP_PACKET_BATCH_FOR_EACH in netdev_dpdk_ring_send
  netdev-bsd: Use DP_PACKET_BATCH_FOR_EACH in netdev_bsd_send.
  odp-execute: Use const qualifer for batch size.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in dp_netdev_run_meter.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in fast_path_processing.
  dpif-netdev: Remove 'cnt' in dp_netdev_input__().

 lib/dpif-netdev.c  | 33 +++++++++++++++------------------
 lib/netdev-bsd.c   |  7 ++++---
 lib/netdev-dpdk.c  | 40 +++++++++++++++++++---------------------
 lib/netdev-linux.c | 17 +++++++++--------
 lib/odp-execute.c  |  3 ++-
 5 files changed, 49 insertions(+), 51 deletions(-)

-- 
2.4.11
_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to