DP_PACKET_BATCH_FOR_EACH macro was introduced early this year as part
of enhancing packet batch APIs. Commit '72c84bc2' implemented this macro
and replaced most of the calling sites with macros and simplified the logic.
However there are still many APIs that needs to be fixed.

This patch series is a simple and straightforward set of changes
aimed at using DP_PACKET_BATCH_FOR_EACH macro at all appropriate places.

The second part of the patch series deals with code cleanup and renaming
few variables to improve the readability of the code. The last patch in
this series fixes a wrong comment.

No functionality changes and performance impact with this series.

v1->v2
 * Add patches from below to this series.
   https://mail.openvswitch.org/pipermail/ovs-dev/2017-September/338673.html

 * Group the patches by theme in the below order.
    6 patches - Use DP_PACKET_BATCH_FOR_EACH
    5 patches - Code Cleanup
    1 patch   - Fix comment.

Bhanuprakash Bodireddy (12):
  conntrack: Use DP_PACKET_BATCH_FOR_EACH macro.
  netdev-linux: Use DP_PACKET_BATCH_FOR_EACH in
    netdev_linux_tap_batch_send.
  netdev-dpdk: Use DP_PACKET_BATCH_FOR_EACH in netdev_dpdk_ring_send
  netdev-bsd: Use DP_PACKET_BATCH_FOR_EACH in netdev_bsd_send.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in dp_netdev_run_meter.
  dpif-netdev: Use DP_PACKET_BATCH_FOR_EACH in fast_path_processing.
  netdev-linux: Clean up netdev_linux_sock_batch_send().
  netdev-dpdk: Cleanup dpdk_do_tx_copy.
  netdev-dpdk: Minor cleanup of netdev_dpdk_send__.
  odp-execute: Use const qualifer for batch size.
  dpif-netdev: Remove 'cnt' in dp_netdev_input__().
  dpif-netdev: Fix comments for pmd_load_cached_ports.

 lib/conntrack.c    | 13 ++++++-------
 lib/dpif-netdev.c  | 37 ++++++++++++++++++-------------------
 lib/netdev-bsd.c   |  7 ++++---
 lib/netdev-dpdk.c  | 40 +++++++++++++++++++---------------------
 lib/netdev-linux.c | 17 +++++++++--------
 lib/odp-execute.c  |  3 ++-
 6 files changed, 58 insertions(+), 59 deletions(-)

-- 
2.4.11

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to