[also CCing Joe on the chance that he wants to comment]

On Fri, Apr 06, 2018 at 09:34:38AM +0000, Jan Scheurich wrote:
> > -----Original Message-----
> > From: Ben Pfaff [mailto:b...@ovn.org]
> > Sent: Wednesday, 04 April, 2018 22:28
> > 
> > Oh, that's weird.  It's as if I didn't read the patch.  Maybe I just
> > read some preliminary version in another thread.
> > 
> > Anyway, you're totally right.  I applied this to master.  If you're
> > seeing problems in another branch, let me know and I will backport.
> 
> Thanks!
> 
> I think the issue was introduced into OVS by the following commit a long time 
> ago. 
> 
> commit 23597df052262dec961fd86eb7c54d10984a1ec0
> Author: Joe Stringer <joestrin...@nicira.com>
> Date:   Fri Jul 25 13:54:24 2014 +1200
> 
> It's a temporary glitch that can cause unexpected behavior only within
> the first few hundred milliseconds after datapath flow creation. It is
> most likely to affect "reactive" controller use cases (MAC learning,
> ARP handling), like the OVN test case that now failed with a small
> change of timing. So it is possible that one could notice short packet
> drops or duplicate PACKET_INs in real SDN deployments when looking
> close enough.
> 
> My preference would be to backport it all the way to OVS 2.5. But of
> course I don't have proof that there are actual problems out in the
> field that it would solve.

OK.

I am going to sit on this for a few days and see whether anyone reports
unusual issues.  If nothing arises, I'll backport as far as reasonable.

Thanks,

Ben.
_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to