On Wed, May 08, 2019 at 09:22:54AM -0700, Toms Atteka wrote:
> This fixes stack overflow issues for odp_actions_from_string.
> As well moved depth check inside parse_odp_key_mask_attr to beginning.
> Added some missing depth reductions.
> 
> Basic manual testing was performed.
> 
> Reported-by:
> https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=13808
> Signed-off-by: Toms Atteka <cpp.code...@gmail.com>

Thanks for fixing this!

Above, as minor points, please don't word-wrap the tag across two lines,
and please use Reported-at instead of Reported-by for a URL reference.

In the patch itself, this approach requires every "return" within
parse_odp_action() to decrement the depth counter.  This is error-prone.
I would prefer to rename parse_odp_action() to parse_odp_action__() and
make a new parse_odp_action() as a wrapper around parse_odp_action__()
that just increments and decrements the depth.  Another approach that
avoids so many decrements would also be OK.

Thanks,

Ben.
_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to