On 7/21/22 11:19, Finn, Emma wrote: > > >> -----Original Message----- >> From: Ilya Maximets <[email protected]> >> Sent: Wednesday 20 July 2022 19:01 >> To: [email protected] >> Cc: Stokes, Ian <[email protected]>; Eelco Chaudron >> <[email protected]>; Finn, Emma <[email protected]>; Ilya >> Maximets <[email protected]> >> Subject: [PATCH v2] odp-execute: Avoid unnecessary logging for action >> implementations. >> >> There is no need to log if the implementation didn't change. >> Scalar one is default, any change will be logged. And availability is not >> really >> important to log at INFO level. Moving these logs to DBG level to avoid >> littering the log file and confusing users. >> We do the same for miniflow_extract and datapath interface >> implementations. >> >> Additionally text of the log message made more readable and uniform with >> the one used for miniflow_extract. >> >> Fixes: 95e4a35b0a1d ("odp-execute: Add function pointers to odp-execute >> for different action implementations.") >> Signed-off-by: Ilya Maximets <[email protected]> >> --- >> >> Version 2: >> - Dropped the change in test macros, filtering still needed for >> the autovalidator build. >> >> lib/odp-execute-private.c | 11 ++++++----- >> 1 file changed, 6 insertions(+), 5 deletions(-) >> > > Changes look good to me. > Acked-by: Emma Finn <[email protected]>
Thanks, Emma and Eelco! Applied to master and 3.0. Best regards, Ilya Maximets. _______________________________________________ dev mailing list [email protected] https://mail.openvswitch.org/mailman/listinfo/ovs-dev
