I am using pyownet on a few Raspberry Pi systems, but one has stopped working.  I have updated the OS, removed and reinstalled pyownet and it still fails.  This is what I see -

pi@pi3ether:~ $ python3
Python 3.7.3 (default, Apr  3 2019, 05:39:12)
[GCC 8.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from pyownet.protocol import proxy
>>> owp = proxy(host='localhost')
>>> owp.dir()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.7/dist-packages/pyownet/protocol.py", line 600, in dir
    raise OwnetError(-ret, self.errmess[-ret], path)
pyownet.protocol.OwnetError: [Errno 5] legacy - IO error: '/'

If I run owdir from command line I get the sensor listing as expected.  I have tried with python 2.7 as well with the same result.  Running the above on another Pi works as expected.

I could reinstall Raspbian and start again, but I would like to understand what has gone wrong.  Any ideas?



Owfs-developers mailing list

Reply via email to