https://bugzilla.redhat.com/show_bug.cgi?id=1579045



--- Comment #2 from Lubomir Rintel <lkund...@v3.sk> ---
(In reply to Lubomir Rintel from comment #1)
> * Package builds fine in mock -- BRs correct

Spoke too soon. Please add "BuildRequires: /usr/bin/git" for the %autosetup
with git to work.

> 1.) Buildroot tar is obsolete:

tag

Also there's one more thing to fix, rpmlint seems somewhat unhappy:

> virt-bootstrap.noarch: E: wrong-script-interpreter 
> /usr/lib/python3.6/site-packages/virtBootstrap/virt_bootstrap.py /usr/bin/env 
> python
> virt-bootstrap.noarch: E: non-executable-script 
> /usr/lib/python3.6/site-packages/virtBootstrap/virt_bootstrap.py 644 
> /usr/bin/env python

If a shebang is needed, then it should be /usr/bin/python3, not /usr/bin/env
python nor /usr/bin/python. Here it is not needed and should be just dropped --
the file is in /usr/lib and doesn't have an executable bit.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are always notified about changes to this product and component
_______________________________________________
package-review mailing list -- package-review@lists.fedoraproject.org
To unsubscribe send an email to package-review-le...@lists.fedoraproject.org

Reply via email to