I'm trying to build packetfence 10.2.0 for ubuntu arm64 and I'm getting an strange error with go-ipset.
I've allredy tried to change the version of ipset in the packetfence.spec but this wasn't helpfull at all. (https://github.com/inverse-inc/packetfence/pull/4821)

Also I got the same error-message on amd64...

Do you have some ideas to solve this issue?


develobuntu:~/packetfence-10.2.0$ dpkg-buildpackage -us -uc -rfakeroot
#Golang binary
install -d -m0744 /home/ryan/packetfence-10.2.0/debian/packetfence-golang-daemon/usr/local/pf/sbin
make -C go all
make[1]: Entering directory '/home/ryan/packetfence-10.2.0/go'
cd cmd/pfhttpd && \
go build && \
mv pfhttpd ../..
# github.com/inverse-inc/go-ipset
/home/ryan/go/pkg/mod/github.com/inverse-inc/go-ipset@v0.0.0-20190925174109-4d5749cc4aa6/ipset.go:160:2: could not determine kind of name for C.ipset_envopt_parse
make[1]: *** [Makefile:22: pfhttpd] Error 2
make[1]: Leaving directory '/home/ryan/packetfence-10.2.0/go'
make: *** [debian/rules:160: install] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary subprocess returned exit status 2

PacketFence-devel mailing list

Reply via email to