Hi, updating my system is giving me tons of problems that at the end are related to this zypper message:
``` > LANG=C sudo zypper in ffmpeg-8-8.1.2-1699.6.pm.35.x86_64 Loading repository data... Reading installed packages... Resolving package dependencies... Problem: 1: the to be installed ffmpeg-8-8.1.2-1699.6.pm.35.x86_64 requires '(libavcodec62 = 8.1.2-1699.6.pm.35 or ffmpeg-8-mini-libs = 8.1.2-1699.6.pm.35)', but this requirement cannot be provided not installable providers: libavcodec62-8.1.2-1699.6.pm.35.i586[ftp.gwdg.de-Essentials] libavcodec62-8.1.2-1699.6.pm.35.x86_64[ftp.gwdg.de-Essentials] libavcodec62-8.1.2-1699.6.pm.35.i586[ftp.gwdg.de-openSUSE_Tumbleweed] libavcodec62-8.1.2-1699.6.pm.35.x86_64[ftp.gwdg.de-openSUSE_Tumbleweed] Solution 1: do not install ffmpeg-8-8.1.2-1699.6.pm.35.x86_64 Solution 2: break ffmpeg-8-8.1.2-1699.6.pm.35.x86_64 by ignoring some of its dependencies nothing provides 'this-is-only-for-build-envs' needed by the to be installed ffmpeg-8-mini-libs-8.1.2-6.1.x86_64 ``` After having a look at the packages in packman I found the problem is caused by the _multibuild file being removed. I don't have permissions to fix it so if someone with permissions can go to https://pmbs.links2linux.de/package/show/Essentials/A_tw-ffmpeg-8?expand=1 , click on "show unmerged sources", then open the _link file and remove the <patches> section (or at least, the <delete name="_multibuild"/> entry), that would fix the build. Actually, I tested on home:antlarr:branches:Essentials/A_tw-ffmpeg-8 that removing that AND updating to the latest version from multimedia:libs fixes the package (the latest changes that were submitted together with the update to 8.1.3 are needed to fix an unrelated compilation issue). About the "Weird usage of multibuild" comment in _link... the "mini" flavor is really needed here since ffmpeg has some dependencies which actually depend on ffmpeg, so we need a minimum version of ffmpeg to build in order to build the dependencies that are used to build the full ffmpeg version. Having that minimal ffmpeg version require a non-existant `this-is-only-for-build-envs` capability makes sure that minimal version is never installed on a user system. Thanks! -- Antonio Larrosa _______________________________________________ Packman mailing list [email protected] https://lists.links2linux.de/cgi-bin/mailman/listinfo/packman
