On 21.12.2014 16:11, Florian Pritz wrote:
> +     "$scriptdir/makepkg-template" \
> +             --template-dir "$testdir/$testcase/templates" \
> +             -p "$testdir/$testcase/PKGBUILD" \
> +             -o "$testdir/$testcase/result" \
> +             &> "$testdir/$testcase/output_full" "${arguments[@]}"

Keeping those files in the testcase directory is actually a bad idea
since they will be left over if you check out an older commit and they
will confuse the test suite. I'll switch this to a tempdir.

> +     exitcode=$?
> +
> +     sed "$testdir/$testcase/output_full" >"$testdir/$testcase/output" \
> +             -e 's|./test/scripts/|./|' \
> +             -e 's| at '$scriptdir'/makepkg-template line [0-9]\+\.$||'
> +     printf "%s\n" "$exitcode" >> "$testdir/$testcase/output"

This leads to a magic number in the expected_output file. I'll switch
this and all testcases to use "exitcode: $exitcode" for more clarity.
(won't resubmit them unless anything else changes)


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to