----- Original Message -----
From: "David Eyler" <[EMAIL PROTECTED]>

> Op #1:  *fRecPOne = *fRecPTwo;
>
> Op #2:  MemMove(fRecPOne, fRecPTwo, sizeof(FlightDB));

They should be the same, as others have noted, and the first is preferable
(as less easy to screw up). The only thing I'd add is to say that

Op #3:  MemMove(fRecPOne, fRecPTwo, sizeof *fRecPOne);

is better than #2 since it doesn't hard-code the type in as many places.


-- 
For information on using the Palm Developer Forums, or to unsubscribe, please see 
http://www.palmos.com/dev/support/forums/

Reply via email to