P.J. Alling wrote:
You should always try out your equipment before doing anything important
to avoid just such embarrassments.

You're right, I should. I don't know why it didn't occur to me that the flash that works just fine with K-5s and K-3s might not work with a K-1. I don't use it that often. Today was the second time I tried to use the combination, the first was a few weeks ago and I was trying to use it as fill doing an outdoors photo shoot, so I just put it in manual. Today I was trying to photograph the puddles in my downstairs to show my contractor where they are coming from. The weird thing is that it *sort of* works. Sometimes the flash will fire in P-TTL, and sometimes not. It acts like dirty contacts. But only in P-ttl, in manual, etc. the flash works fine.

The google monster made me realize that I wasn't the only one with this problem.

A friend didn't take that advice and when demonstrating a jet turbine
powered electric generator had it violently explode during the
demonstration. It was embarrassing to the tune of about 2 million dollars.

Not that I'm suggesting that you experienced that level of
embarrassment, but it's a cautionary tail, and it's pretty funny, /now/,

Nope, not even close.

Thank goodness.

And, as I also mentioned it turns out that they only have the firmware updates for Windows, not for Mac or Linux. Grumble.

On 10/16/2016 8:16 PM, Larry Colen wrote:
My metz flash would not work in p-ttl with the K-1. It turns out that
it needs a software upgrade:

Just so that other people don't find this out in the middle of a shoot
like I did.

Larry Colen  l...@red4est.com (postbox on min4est) http://red4est.com/lrc

PDML Pentax-Discuss Mail List
to UNSUBSCRIBE from the PDML, please visit the link directly above and follow 
the directions.

Reply via email to