Obviously I'm doing something wrong - just have no clue what. More so than usual.

Previously I've been using the PowerAdmin web GUI. Worked great - but seems like it's lacking recent development. And I couldn't get my SRV record to be accepted.

So I've started using PowerDNS-Admin. Which also seems great. But...it does not (at least for me at this time) appear to include support for creating SRV records.

I'm currently using a MySQL backend. So I tried poking a record in directly - which didn't do well.

Finally, thought I'd go right to the horse's...ear? pdnsutil add-record. And...I get the very informative message "missing field at the end of record content".

Since I freely admit I'm clueless on the correct format of the SRV records (I'm simply trying to setup my LAN to hopefully be a little more self-administrating) - I could use some guidance. I've never seen a "full" example, particularly using pdnsutil, which would help tremendously. My intent:

I have a zone "mydomain.lan". I have successfully created:

b._dns-sd._udp as a PTR, with value "mydomain.lan".
lb._dns-sd as a PTR, with value "mydomain.lan"

But now I am attempting:

pdnsutil add-record mydomain.lan HP_Officejet_Pro_X576dw_MFP._tcp.mydomain.lan srv 0 0 631 server.mydomain.lan Error: Parsing record content (try 'pdnsutil check-zone'): missing field at the end of record content '0'

What perfectly obvious blunder am I making?
Pdns-users mailing list

Reply via email to