One correction below:

Corey Ashford wrote:
...
> To flesh out the group definition with the above in mind, perhaps it could 
> look 
> like this:
> 
> struct attribute_macro {
>       const char *name;
>       const char *translation;
> };
> 
> struct macro_group {
>       union {
>               uint32_t        flags;
>               uint32_t        is_hard_wired:1
>                               is_dfl:1;
>                               reserved:30;
>       }
>          int ngroups;
>       struct attribute_macro *group[];
> }

The macro_group's last two elements should be renamed as follows:

struct macro_group {
        union {
                uint32_t        flags;
                uint32_t        is_hard_wired:1
                                is_dfl:1; /* 0 = no default,
                                           * 1 = macro[0] is the default
                                           */
                                reserved:30;
        }
        int nmacros;
        struct attribute_macro *macros[];
}

- Corey


------------------------------------------------------------------------------
Return on Information:
Google Enterprise Search pays you back
Get the facts.
http://p.sf.net/sfu/google-dev2dev
_______________________________________________
perfmon2-devel mailing list
perfmon2-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/perfmon2-devel

Reply via email to