From 52c50aea8ad7e6f64a3ea9b5abe122e59629282f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <s...@fedoraproject.org>
Date: Mon, 6 Mar 2006 15:43:20 +0000
Subject: - 1.4.1. - Don't hardcode required pcsc-lite-libs version, use shared
 lib file     instead. - Convert docs to UTF-8.

---
 .cvsignore     |  2 +-
 pcsc-perl.spec | 20 +++++++++++++-------
 sources        |  2 +-
 3 files changed, 15 insertions(+), 9 deletions(-)

diff --git a/.cvsignore b/.cvsignore
index cb36d45..2939122 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-pcsc-perl-1.3.1.tar.gz
+pcsc-perl-1.4.1.tar.gz
diff --git a/pcsc-perl.spec b/pcsc-perl.spec
index fee1b27..825c242 100644
--- a/pcsc-perl.spec
+++ b/pcsc-perl.spec
@@ -1,8 +1,9 @@
-%define pcscver 1.2.0
+%define pcscver 1.3.0
+%define pcsclib %{_libdir}/libpcsclite.so.1
 
 Name:           pcsc-perl
-Version:        1.3.1
-Release:        8%{?dist}
+Version:        1.4.1
+Release:        1%{?dist}
 Summary:        Perl interface to the PC/SC smart card library
 
 Group:          Development/Libraries
@@ -12,8 +13,8 @@ Source0:        
http://ludovic.rousseau.free.fr/softwares/pcsc-perl/%{name}-%{ve
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  perl
-BuildRequires:  pcsc-lite-devel = %{pcscver}
-Requires:       pcsc-lite-libs = %{pcscver}
+BuildRequires:  pcsc-lite-devel >= %{pcscver}
+Requires:       %{pcsclib}
 Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
 Provides:       perl-pcsc = %{version}-%{release}
 
@@ -25,11 +26,11 @@ library.
 %prep
 %setup -q
 chmod 644 examples/* # avoid dependencies
+f=README ; iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
 
 
 %build
-%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" \
-  DEFINE=-Wall INC=
+%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" DEFINE=-Wall
 make %{?_smp_mflags}
 
 
@@ -59,6 +60,11 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Mon Mar  6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1
+- 1.4.1.
+- Don't hardcode required pcsc-lite-libs version, use shared lib file instead.
+- Convert docs to UTF-8.
+
 * Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-8
 - Rebuild, cosmetics.
 
diff --git a/sources b/sources
index da791e6..bc8dba5 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-4c1869b5b726f7ab5b1bda88b390c821  pcsc-perl-1.3.1.tar.gz
+0a432f4fd6414aa3122b53a091b47064  pcsc-perl-1.4.1.tar.gz
-- 
cgit v0.12


        
http://pkgs.fedoraproject.org/cgit/pcsc-perl.git/commit/?h=epel7&id=52c50aea8ad7e6f64a3ea9b5abe122e59629282f
_______________________________________________
perl-devel mailing list -- perl-devel@lists.fedoraproject.org
To unsubscribe send an email to perl-devel-le...@lists.fedoraproject.org

Reply via email to