From 68a931fb9c6cb1c8c2be14b7df9fbd40a87a69df Mon Sep 17 00:00:00 2001
From: Paul Howarth <p...@city-fan.org>
Date: Sun, 3 Jul 2016 15:25:01 +0100
Subject: Update to 1.801

- New upstream release 1.801
  - Fixed race condition in Queue->await
  - MCE 1.801 is stable on all supported platforms
  - Completed work supporting cyclical include of MCE Core / Models
  - Updated MCE to support Perl included with Git Bash
  - Renamed temp dir from 'mce' to 'Perl-MCE' under user's %%TEMP%% location on
    Windows, e.g. Native Perl, Cygwin, Git Bash
- BR: perl-generators unconditionally
---
 .gitignore    |  1 +
 perl-MCE.spec | 16 +++++++++++-----
 sources       |  2 +-
 3 files changed, 13 insertions(+), 6 deletions(-)

diff --git a/.gitignore b/.gitignore
index c282551..1eab696 100644
--- a/.gitignore
+++ b/.gitignore
@@ -14,3 +14,4 @@
 /MCE-1.707.tar.gz
 /MCE-1.708.tar.gz
 /MCE-1.800.tar.gz
+/MCE-1.801.tar.gz
diff --git a/perl-MCE.spec b/perl-MCE.spec
index 3bd0125..8342eb3 100644
--- a/perl-MCE.spec
+++ b/perl-MCE.spec
@@ -1,5 +1,5 @@
 Name:           perl-MCE
-Version:        1.800
+Version:        1.801
 Release:        1%{?dist}
 Summary:        Many-core Engine for Perl providing parallel processing 
capabilities
 License:        GPL+ or Artistic
@@ -12,9 +12,7 @@ BuildRequires:  coreutils
 BuildRequires:  findutils
 BuildRequires:  make
 BuildRequires:  perl
-%if 0%{?fedora} > 20 || 0%{?rhel} > 7
 BuildRequires:  perl-generators
-%endif
 BuildRequires:  perl(ExtUtils::MakeMaker)
 BuildRequires:  perl(strict)
 BuildRequires:  perl(warnings)
@@ -27,7 +25,6 @@ BuildRequires:  perl(Exporter)
 BuildRequires:  perl(Fcntl)
 BuildRequires:  perl(File::Path)
 BuildRequires:  perl(IO::Handle)
-BuildRequires:  perl(POSIX)
 BuildRequires:  perl(Scalar::Util)
 BuildRequires:  perl(Socket)
 BuildRequires:  perl(Storable) >= 2.04
@@ -44,7 +41,6 @@ BuildRequires:  perl(Test::More) >= 0.88
 # Dependencies
 Requires:       perl(:MODULE_COMPAT_%(eval "$(perl -V:version)"; echo 
$version))
 Requires:       perl(IO::Handle)
-Requires:       perl(POSIX)
 Requires:       perl(Storable) >= 2.04
 Requires:       perl(threads::shared)
 
@@ -140,6 +136,16 @@ make test
 %{_bindir}/mce_grep
 
 %changelog
+* Sun Jul  3 2016 Paul Howarth <p...@city-fan.org> - 1.801-1
+- Update to 1.801
+  - Fixed race condition in Queue->await
+  - MCE 1.801 is stable on all supported platforms
+  - Completed work supporting cyclical include of MCE Core / Models
+  - Updated MCE to support Perl included with Git Bash
+  - Renamed temp dir from 'mce' to 'Perl-MCE' under user's %%TEMP%% location on
+    Windows, e.g. Native Perl, Cygwin, Git Bash
+- BR: perl-generators unconditionally
+
 * Sun Jun 19 2016 Paul Howarth <p...@city-fan.org> - 1.800-1
 - Update to 1.800
   - Fixed dequeue (count) in MCE::Queue for standalone mode
diff --git a/sources b/sources
index 60b2a6b..d7c919b 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-6804cc54b7107463d406c27fe82c1b91  MCE-1.800.tar.gz
+903a76c9348f4c05fb36ac1e75251f0e  MCE-1.801.tar.gz
-- 
cgit v0.12


        
http://pkgs.fedoraproject.org/cgit/perl-MCE.git/commit/?h=f24&id=68a931fb9c6cb1c8c2be14b7df9fbd40a87a69df
_______________________________________________
perl-devel mailing list -- perl-devel@lists.fedoraproject.org
To unsubscribe send an email to perl-devel-le...@lists.fedoraproject.org

Reply via email to