From 402c5140e84b8b02d17846e174bff0f032a95819 Mon Sep 17 00:00:00 2001
From: "Richard M. Shaw" <hobbes1...@gmail.com>
Date: Thu, 13 Oct 2016 10:36:30 -0500
Subject: Update to latest upstream release.

---
 .gitignore                  |  1 +
 ChangeLog                   | 47 ---------------------------------------------
 abi-compliance-checker.spec |  9 ++++++---
 sources                     |  2 +-
 4 files changed, 8 insertions(+), 51 deletions(-)
 delete mode 100644 ChangeLog

diff --git a/.gitignore b/.gitignore
index 9572ba3..68f26b0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -24,3 +24,4 @@
 /abi-compliance-checker-1.99.13.tar.gz
 /abi-compliance-checker-1.99.19.tar.gz
 /abi-compliance-checker-1.99.20.tar.gz
+/abi-compliance-checker-1.99.25.tar.gz
diff --git a/ChangeLog b/ChangeLog
deleted file mode 100644
index de0037a..0000000
--- a/ChangeLog
+++ /dev/null
@@ -1,47 +0,0 @@
-Version 1.99.19 (April 18, 2016)
-Improvements
-
-Support for GCC 5.1
-Misc
-Separated LICENSE file
-Removed obsolete descriptors from the package
-Updated docs
-
-Version 1.99.18 (April 03, 2016)
-Bug Fixes
-Fixed comparison of qualifiers in parameter data types
-Fixed problem descriptions in the report
-Reduced size of the report
-Fixed console output
-
-Version 1.99.17 (March 12, 2016)
-Improvements
-Added a check for changes in parameters of function pointers
-Bug Fixes
-Fixed comparison of virtual table entries
-Do not show time stamp in the report
-Fixed -skip-symbols option
-Fixed detection of the GCC version number
-
-Version 1.99.16 (January 28, 2016)
-Improvements
-Do not check private part of the ABI when comparing ABI dumps created by the
-ABI Dumper tool with use of the -public-headers option
-New Options
--check-private-abi: enable check of the private ABI
-Bug Fixes
-Fixed counting of checked data types
-
-Version 1.99.15 (December 11, 2015)
-Bug Fixes
-Fixed hang on some template instances
-Fixed support for old ABI dumps (formatting of data types)
-Fixed false positives in the report if input ABI dumps contain __unknown__
-types
-
-Version 1.99.14 (November 01, 2015)
-New Options
--skip-types: set list of types that should not be checked
-Bug Fixes
-Fixed formatting of symbol signatures
-Fixed checks of template types
diff --git a/abi-compliance-checker.spec b/abi-compliance-checker.spec
index 45551c8..a6ef6fa 100644
--- a/abi-compliance-checker.spec
+++ b/abi-compliance-checker.spec
@@ -1,5 +1,5 @@
 Name:           abi-compliance-checker
-Version:        1.99.20
+Version:        1.99.25
 Release:        1%{?dist}
 Summary:        An ABI Compliance Checker
 
@@ -15,7 +15,8 @@ Requires:       gcc >= 4.5
 Requires:       gcc-c++ >= 4.5
 Requires:       binutils
 Requires:       ctags >= 5.8
-Requires:       ccache > 3.1.2
+Requires:       ccache >= 3.1.2
+Requires:       abi-dumper >= 0.99.15
 
 %{?perl_default_filter}
 
@@ -39,7 +40,6 @@ perl Makefile.pl -install --prefix=%{_prefix} 
--destdir=%{buildroot}
 
 
 %files
-%{!?_licensedir:%global license %doc}
 %license LICENSE GPL-2.0 LGPL-2.0
 %doc README doc/*
 %{_bindir}/%{name}
@@ -47,6 +47,9 @@ perl Makefile.pl -install --prefix=%{_prefix} 
--destdir=%{buildroot}
 
 
 %changelog
+* Thu Oct 13 2016 Richard Shaw <hobbes1...@gmail.com> - 1.99.25-1
+- Update to latest upstream release.
+
 * Mon May 16 2016 Richard Shaw <hobbes1...@gmail.com> - 1.99.20-1
 - Update to latest upstream release.
 
diff --git a/sources b/sources
index b8138e9..f428a52 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-151147f75e999f6e0a3974ce32d23932  abi-compliance-checker-1.99.20.tar.gz
+cc4f8e5351c895d325e8010c83931aa4  abi-compliance-checker-1.99.25.tar.gz
-- 
cgit v0.12


        
http://pkgs.fedoraproject.org/cgit/abi-compliance-checker.git/commit/?h=master&id=402c5140e84b8b02d17846e174bff0f032a95819
_______________________________________________
perl-devel mailing list -- perl-devel@lists.fedoraproject.org
To unsubscribe send an email to perl-devel-le...@lists.fedoraproject.org

Reply via email to