From cdb526667272dde002ac7311e972fafeb3bc0ae1 Mon Sep 17 00:00:00 2001
From: Robert Scheck <rob...@fedoraproject.org>
Date: Fri, 14 Oct 2016 10:06:04 +0200
Subject: Buildrequire libfbclient.so rather firebird-devel to cover building
 with firebird 2.5.x and 3.0.x without conditionals

---
 perl-DBD-Firebird.spec | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/perl-DBD-Firebird.spec b/perl-DBD-Firebird.spec
index 7bd8efb..1a68a23 100644
--- a/perl-DBD-Firebird.spec
+++ b/perl-DBD-Firebird.spec
@@ -6,7 +6,7 @@
 Summary:        A Firebird interface for perl
 Name:           perl-DBD-Firebird
 Version:        1.22
-Release:        2%{?dist}
+Release:        3%{?dist}
 License:        GPL+ or Artistic
 Group:          Development/Libraries
 URL:            http://search.cpan.org/dist/%{pkgname}/
@@ -15,7 +15,7 @@ Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} 
-V:version`"; echo $versi
 BuildRequires:  coreutils
 BuildRequires:  findutils
 BuildRequires:  firebird >= 2.5.1
-BuildRequires:  firebird-devel >= 2.5.1
+BuildRequires:  %{_libdir}/libfbclient.so
 BuildRequires:  make
 BuildRequires:  perl >= 5.10.1
 BuildRequires:  perl-devel
@@ -85,6 +85,10 @@ make test
 %{_mandir}/man3/*.3*
 
 %changelog
+* Fri Oct 14 2016 Robert Scheck <rob...@fedoraproject.org> 1.22-3
+- Buildrequire libfbclient.so rather firebird-devel to cover
+  building with firebird 2.5.x and 3.0.x without conditionals
+
 * Sun May 15 2016 Jitka Plesnikova <jples...@redhat.com> - 1.22-2
 - Perl 5.24 rebuild
 
-- 
cgit v0.12


        
http://pkgs.fedoraproject.org/cgit/perl-DBD-Firebird.git/commit/?h=master&id=cdb526667272dde002ac7311e972fafeb3bc0ae1
_______________________________________________
perl-devel mailing list -- perl-devel@lists.fedoraproject.org
To unsubscribe send an email to perl-devel-le...@lists.fedoraproject.org

Reply via email to