On Sunday, October 13, 2002, at 10:05  AM, Tony Bowden wrote:

>>       Makes it simpler for people who prefer the 'no_plan' style of
>>       testing
>
> Maybe this is what I just don't get. I'm not one of those people, so I
> don't really understand why people might prefer it. Especially here
> where there's such a natural way to specify them, and you're only
> counting them per method, rather than over the entire test.

I have to agree with Tony. I think it's important to explicitly 
indicate the number of tests that a given method runs, and to be 
explicit about saying when you're not sure how many tests there will 
be. In that regard, I like the current design better, although I would 
have no complaint if you decided to change the string "no_plan" to 
something else.

What I would like to see changed, however, is when a method indicates a 
number of tests, and then runs fewer than that, but doesn't complain. 
This is because of the skip feature, where you can return from a method 
early when you want to skip the rest of the tests. But if you just have 
too few tests, it silently succeeds. I think that this issue can be 
circumvented by requiring a string to be returned from a method when 
you want to skip the remainder of the tests. A silent return would fail.

Regards,

David

-- 
David Wheeler                                     AIM: dwTheory
[EMAIL PROTECTED]                                 ICQ: 15726394
http://david.wheeler.net/                      Yahoo!: dew7e
                                                Jabber: [EMAIL PROTECTED]

Reply via email to