----- Original Message ----- 
From: "listmail" <[EMAIL PROTECTED]>
To: <perl-win32-users@listserv.ActiveState.com>
Sent: Wednesday, November 05, 2008 4:43 AM
Subject: Net::SSH2 v0.18


>I can't get Net::SSH2 0.18 working.  I had Net::SSH2 0.09 working
> without having to do any extra steps, but I never migrated my programs
> over from using the old Net::SSH::W32Perl.
>
> I installed 0.18 via the default repo, it failed the test, removed it
> and installed from ppm install
> http://theoryx5.uwinnipeg.ca/ppms/Net-SSH2.ppd which is the same
> version, and it failed with the same error.

(Aside: I'm finding that ppm installs from uwinnipeg are very slow these 
days. Is that just low bandwidth being provided by the server ? ... or 
something else. It took me about 30 minutes to install Net-SSH2-0.18, and 
I've noticed slow downloads with all of the other modules I've recently 
installed from that repo. Anyone else noticed the same ? Downloads from the 
ActiveState repo still proceed quite quickly for me.)
>
> To test i simply create a perl script with a use Net::SSH2; call and
> then run it and I immediately get this error:
>
> Can't load 'C:\perl\site\lib/auto/Net/SSH2/SSH2.dll' for module
> Net::SSH2: load_file:The specified procedure could not be found at
> C:\perl\site\lib/XSLoader.pm line 64.
> at C:\perl\site\lib/Net/SSH2.pm line 466
> Compilation failed in require at C:\testing\ssh2.pl line 5.
> BEGIN failed--compilation aborted at C:ssh2.pl line 5.

Presumably you get the same behaviour with:
perl -MNet::SSH2 -e "print $Net::SSH2::VERSION"

>
> The file C:\perl\site\lib\auto\Net\SSH2\SSH2.dll does exist (path
> delimeters corrected vs. what is above) but this error sounds like
> (speculation on my part) either that SSH2.dll doesn't contain code that
> it should have or some other dependency is missing, but I thought that
> would should have been handled by the ppm install process.

I think that's all fairly accurate - though there is no other dependency for 
that SSH2.dll.
Term::ReadKey is needed (and should have been installed if missing), but I 
think that has no bearing on this particular problem.

> ActivePerl 5.8.8 820
> Windows XP SP2

I have ActivePerl 5.8.8 824. I ran:

------------------------------------------------

C:\_32>ppm remove Net-SSH2
Net-SSH2: uninstalled

C:\_32>ppm install http://theoryx5.uwinnipeg.ca/ppms/Net-SSH2.ppd
Downloading Net-SSH2-0.18...done
Unpacking Net-SSH2-0.18...done
Generating HTML for Net-SSH2-0.18...done
Updating files in site area...done
  13 files installed
   7 files updated

C:\_32>perl -MNet::SSH2 -e "print $Net::SSH2::VERSION"
0.18
C:\_32>
------------------------------------------------

As you can see, it all seems to be working fine for me. I don't think your 
problem has anything to do with the ppm package itself.
Could you run through that same procedure I used - making sure that the 
SSH2.pm and SSH2.dll are, in fact, being removed by the 'ppm remove 
Net-SSH2' command.

Cheers,
Rob 

_______________________________________________
Perl-Win32-Users mailing list
Perl-Win32-Users@listserv.ActiveState.com
To unsubscribe: http://listserv.ActiveState.com/mailman/mysubs

Reply via email to