Branch: refs/heads/smoke-me/khw-pr_curly
  Home:   https://github.com/Perl/perl5
  Commit: 77fdf1591c658571b176ad24e3fac8e2304d3e2b
      
https://github.com/Perl/perl5/commit/77fdf1591c658571b176ad24e3fac8e2304d3e2b
  Author: Karl Williamson <[email protected]>
  Date:   2020-11-15 (Sun, 15 Nov 2020)

  Changed paths:
    M regcomp.c

  Log Message:
  -----------
  regcomp.c: Change names of 2 macros to for mnemonics

The new names are more understandable to me.  This also adds a second
parameter to one macro, that is unused until the next commit in the
series.


  Commit: b2ab5806b77a3f03a1732b6ac603b720bfbf85c8
      
https://github.com/Perl/perl5/commit/b2ab5806b77a3f03a1732b6ac603b720bfbf85c8
  Author: Karl Williamson <[email protected]>
  Date:   2020-11-15 (Sun, 15 Nov 2020)

  Changed paths:
    M embed.fnc
    M embed.h
    M inline.h
    M proto.h
    M regcomp.c
    M toke.c

  Log Message:
  -----------
  Revamp regcurly(), regpiece() use of it

This commit copies portions of new_regcurly(), which has been around
since 5.28, into plain regcurly(), as a baby step in preparation for
converting entirely to the new one.  These functions are used for
parsing {m,n} quantifiers.  The new version will add capabilities not
in the old.

The commit adds an optional parameter to return to the caller,
information it gleans during parsing about where the bounds are for the
numbers in the quantifier string.

This commit changes regpiece() to use this information, instead of
itself reparsing (which could have led to things being out-of-sync), and
places the bounds handling in a separate function, instead of having
near duplicate code for the lower and upper bounds


Compare: https://github.com/Perl/perl5/compare/77fdf1591c65%5E...b2ab5806b77a

Reply via email to