Branch: refs/heads/yves/manifest_dev
Home: https://github.com/Perl/perl5
Commit: 89528f5c2f5cc65c96d5bcdd3f31dee162a0a2e7
https://github.com/Perl/perl5/commit/89528f5c2f5cc65c96d5bcdd3f31dee162a0a2e7
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M Porting/manicheck
Log Message:
-----------
manicheck: fix broken exitcode logic
The comment says the highest exit code we should return is 124, but the
code will return 125 if there are 125 problems, if it is higher than 125
it will return 124. Which doesn't make sense.
This patch changes the logic to do what the comment says, return 124 if
there are 124 or more problems, otherwise it returns the count of
problems.
Commit: 0068e39a31f9d41dfc08d27c9e5b117872e96b2d
https://github.com/Perl/perl5/commit/0068e39a31f9d41dfc08d27c9e5b117872e96b2d
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M MANIFEST
M Makefile.SH
A Porting/MANIFEST.dev
M Porting/README.pod
M Porting/manicheck
M Porting/manifest_lib.pl
M Porting/release_managers_guide.pod
M t/porting/exec-bit.t
M t/porting/known_pod_issues.dat
M t/porting/manifest.t
M t/porting/readme.t
Log Message:
-----------
Create Porting/MANIFEST.dev as a complement to MANIFEST and related infra
This file is intended to list all the files in the repo which are not
listed in the main MANIFEST file, and which are used only for
development purposes, especially those files which are only useful when
working in a git checkout of the main perl git repository.
The files it contains will NOT be added to the production tarball
release. The file has the exact same format as the main MANIFEST:
"file\t+description" or "file".
Q. Why didn't I call this Porting/MANIFEST as mentioned in the
discussion thread that lead to this patch?
A. The main reason was that Porting/README.pod includes a list of files
in Porting with descriptions and explanations for what the files do
or how they are used. In several places the file refers to
"MANIFEST", which lead to ambiguity that would have had to be
resolved by changing all the entries to refer to "Porting/whatever"
instead. It was much simpler to give the new file an extension, and I
thought that '.dev' suggests it is for "development" purposes.
Q. Why isn't this using MANIFEST.skip style functionality?
A1. Various parts of our build and test process expect to read the
MANIFEST file and then do things based on the entries contained
within. Eg, run tests, or extract data, or compare the file list to
content in another file. Those parts of our build process would
break if we used a skip style list of regexen. So it would be more
work to teach them to deal with such a file, assuming it was
actually doable - given the additional work I have not considered it
deeply. On the other hand teaching that logic to simply read two
files was and is easy.
A2. I think each file we have in the repo should have a description.
This patch currently doesn't provide a description for each, but it
does for many, especially those migrated from MANIFEST.
A3. I think that MANIFEST.skip style files of exclusion regexens and
globs are error prone and easy to mess up, for instance by excluding
far more than you had intended to. They can also be annoying to get
right, obviously not impossible, but sometimes annoying. Explicitly
listing everything is easy in every way, especially to mechanize.
A4. I would like to be able to move verbatim entries from our existing
MANIFEST into the new Porting/MANIFEST.dev, description and all.
MANIFEST.skip style files do not support descriptions except as
comments as far as I recall. That would have meant munging the data
from MANIFEST during the move process which would be annoying.
A5. I would like to be able to reuse our sorting logic to keep the files
nicely sorted in a way where the file is somewhat readable. A list
of skip files would be less amenable to doing so.
Q. There is a lot of duplicated logic related to testing manifests,
should we refactor it out into a module or some resuable tool set?
A. YES! We already have Porting/manifest_lib.pm, but it currently does
not declare a package, and it only contains one function. Instead of
adding yet more code that depends on requiring a file and having it
inject subs into package main I decided that doing the refactoring
could wait for a separate commit or PR. But I definitely think we
should refactor as much of this logic as possible.
Q. Some of the test files were fairly significantly changed, are you
sure you didn't break or drop any of the tests?
A. I am reasonably confident I did not. Secondary review appreciated.
Some of the touched files are quite old and obviously "quick hack"
scripts. By rewriting them quite a bit I was able to simplify and
perform some of the tests in different ways or parts of the script.
As far as I know I didn't drop any.
Q. Why didn't you use newer features in the rewrite?
A. I am a bit conservative in my taste, and I like build tools to be
able to run on older perls, and for things like this I prefer to
stick with what I know well. Patches welcome.
Q. Why didn't you move more of the stuff we shouldn't bundle with
our releases?
A. I figured someone like Nicolas R. (who helped motivate this patch)
would feel left out if I didn't leave him anything to do. :-)
Commit: 5cd4d89bc1af546b6cb52b318a1b01cbef8934f2
https://github.com/Perl/perl5/commit/5cd4d89bc1af546b6cb52b318a1b01cbef8934f2
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M Porting/Maintainers.pm
Log Message:
-----------
Teach Porting/Maintainers.pm about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: 3c1d8e620193879ec02a31e8165d198291555828
https://github.com/Perl/perl5/commit/3c1d8e620193879ec02a31e8165d198291555828
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M Porting/check83.pl
Log Message:
-----------
Teach Porting/check83.pl about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: 2db617226bdc2c36f9a1c5a6238837379dff739c
https://github.com/Perl/perl5/commit/2db617226bdc2c36f9a1c5a6238837379dff739c
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M Porting/checkcfguse.pl
Log Message:
-----------
Teach Porting/checkcfguse.pl about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: 5a5eccb3d64f81e29f38bd6277bf6fe581c2b5b9
https://github.com/Perl/perl5/commit/5a5eccb3d64f81e29f38bd6277bf6fe581c2b5b9
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M t/TEST
Log Message:
-----------
Teach t/TEST about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: ca78d0cbef0228f2933845ba546f01dce1624e13
https://github.com/Perl/perl5/commit/ca78d0cbef0228f2933845ba546f01dce1624e13
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M t/porting/filenames.t
Log Message:
-----------
Teach t/porting/filenames.t about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: 3cd79ce5279d1b785ba255b06a121d4141e98973
https://github.com/Perl/perl5/commit/3cd79ce5279d1b785ba255b06a121d4141e98973
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M t/porting/podcheck.t
Log Message:
-----------
Teach t/porting/podcheck.t about Porting/MANIFEST.dev
Patch best viewed with -w
Commit: ff9e589c1ed06a24bbb645ff125f853b255b986f
https://github.com/Perl/perl5/commit/ff9e589c1ed06a24bbb645ff125f853b255b986f
Author: Yves Orton <[email protected]>
Date: 2022-03-11 (Fri, 11 Mar 2022)
Changed paths:
M t/porting/utils.t
Log Message:
-----------
Teach t/porting/utils.t about Porting/MANIFEST.dev
Patch best viewed with -w
Compare: https://github.com/Perl/perl5/compare/57bbb9b4804c...ff9e589c1ed0