Branch: refs/heads/blead Home: https://github.com/Perl/perl5 Commit: fee9e82c332007c8e28df7eed5fc8ef151fb6698 https://github.com/Perl/perl5/commit/fee9e82c332007c8e28df7eed5fc8ef151fb6698 Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024)
Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): balance braces Within the long subroutine process_file(), make '{' and '}' be balanced, so that it's easier to bounce around between matching braces using '%' on vim, or the equivalent on other text editors. This is achieved by fixing a couple comment typos, plus using the '[[' and ']]' escapes in a few Q(<<EOF) calls which output unbalanced braces but were using a bare '{' or '}'. Most of code-output heredocs in this sub already used the escapes, just these few weren't. Commit: 643951018133882e3c72a8676a4ca4a903e057ec https://github.com/Perl/perl5/commit/643951018133882e3c72a8676a4ca4a903e057ec Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): rename some lex vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. Rename %args to %Options. This hash records the various switches passed to the sub, but its name can get confused with many other vars with 'arg' in their name used later for parsing an XSUB's signature. At the same time, rename the minor %options var to %opts. Commit: 6b07631c3f059ee8a13988810b1c4dbef07a491c https://github.com/Perl/perl5/commit/6b07631c3f059ee8a13988810b1c4dbef07a491c Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): adj scope of some my vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. This commit reduces the scope of a few lexical vars from being in the whole scope of the big sub (or the big loop within it) to just where they are used. Commit: 604e99f829eb4957371608b36544a2316eea1adc https://github.com/Perl/perl5/commit/604e99f829eb4957371608b36544a2316eea1adc Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): adjust some indents After the previous commit which added some new { } scopes, re-indent the code within the new scopes. Whitespace-only change (plus wrapping one over-long comment). Commit: 6a7b75822016af67aef832118a17d9d697499860 https://github.com/Perl/perl5/commit/6a7b75822016af67aef832118a17d9d697499860 Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): rename more my vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. Rename various boolean lexical vars to $seen_FOO, where FOO is something in the XSUB that has been detected. was now $RETVAL_no_return $seen_NO_RETURN $externC $seen_extern_C $static $seen_static $ellipsis $seen_ellipsis $PPCODE $seen_PPCODE $CODE $seen_CODE $INTERFACE $seen_INTERFACE Commit: 1903ccbf15888174dea12e4bbff358d4f1ee179f https://github.com/Perl/perl5/commit/1903ccbf15888174dea12e4bbff358d4f1ee179f Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): rename yet more my vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. These are miscellaneous renames for clarity: was now $XSS_work_idx $XSS_top_if_idx $cpp_next_tmp $cpp_next_tmp_define $xsreturn $XSRETURN_count $len_name $name_or_lenname $islength $is_length $num_args $args_count $min_args $min_arg_count $extra_args $optional_args_count @args_num @map_param_idx_to_arg_idx $wantRETVAL $implicit_OUTPUT_RETVAL $trgt $target Commit: f994f0e1441aa79773c930eff098718c53d0b64e https://github.com/Perl/perl5/commit/f994f0e1441aa79773c930eff098718c53d0b64e Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): fix couple of my vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. This commit: Deletes the unused $inout_var variable. Reduces the scope of the $EXPLICIT_RETURN variable. Commit: 64e08b7222b63a56ec58622a5c98958210854b42 https://github.com/Perl/perl5/commit/64e08b7222b63a56ec58622a5c98958210854b42 Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): rename 2 ref my vars process_file() is a long sub of about 1600 lines. This commit is one of a series to rename etc some of its lexical vars for greater clarity and consistency. This commit converts a couple of vars called $foo_ref which are references to an array or hash, into a direct array or hash. These vars are used just locally to the sub and aren't passed anywhere else, so it seems little point in making them references. was now $only_C_inlist_ref @only_C_inlist $outlist_ref @OUTLIST_vars The declaration of @OUTLIST_vars is also moved down to be nearer to where the variable is first used. Commit: 6fd781fb96cc56baef48a52c97029b1319c5a192 https://github.com/Perl/perl5/commit/6fd781fb96cc56baef48a52c97029b1319c5a192 Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): eliminate 2 postfix fors There are a couple of multi-line statements with a 'for foo' suffix. Turn them into a proper 'for { block }' instead, as it's easy to miss the trailing 'for' when visually inspecting such code. Commit: 1c57501b4fdb39475946e9c6f27c49c0810d6e20 https://github.com/Perl/perl5/commit/1c57501b4fdb39475946e9c6f27c49c0810d6e20 Author: David Mitchell <da...@iabyn.com> Date: 2024-08-03 (Sat, 03 Aug 2024) Changed paths: M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm Log Message: ----------- ParseXS::process_file(): merge 2 prints Two code-emitting print statements follow one from another. Merge into a single staement. This is a trivial simplification with no change to output. Compare: https://github.com/Perl/perl5/compare/21dc39114827...1c57501b4fdb To unsubscribe from these emails, change your notification settings at https://github.com/Perl/perl5/settings/notifications