Branch: refs/heads/blead
  Home:   https://github.com/Perl/perl5
  Commit: 36cf05fe2cca34ad65f679000f82a43c0e335797
      
https://github.com/Perl/perl5/commit/36cf05fe2cca34ad65f679000f82a43c0e335797
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: passed string isn't always in same buffer

It is passed the current parse position, and presumes the upper end of
the string is PL_bufend.  But that is a bad assumption.  Since
f05e27e5b9a in 2006, it can be called from elsewhere.

Use strlen() to find its end


  Commit: 198096f8163ffff724439029c62d643fcc414e09
      
https://github.com/Perl/perl5/commit/198096f8163ffff724439029c62d643fcc414e09
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Convert body to switch()

This will make the code cleaner and easier to maintain


  Commit: 4dcbd860acfe6d68cd1626d0b2caa4e03014d6bc
      
https://github.com/Perl/perl5/commit/4dcbd860acfe6d68cd1626d0b2caa4e03014d6bc
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Move tiny case: to start of switch()

This keeps it from getting lost in all the big case: code sections


  Commit: bfdeb7e2ef92b03fb0eb43594c35ef367ec86ceb
      
https://github.com/Perl/perl5/commit/bfdeb7e2ef92b03fb0eb43594c35ef367ec86ceb
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Move declarations close to first use


  Commit: a71fb3b696594e381b10fac02d73a38ac9d4883e
      
https://github.com/Perl/perl5/commit/a71fb3b696594e381b10fac02d73a38ac9d4883e
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Convert else if' series to switch()

This is easier to maintain


  Commit: b32c83ee037d325a9fb68d4d1f6bccc0433cf64e
      
https://github.com/Perl/perl5/commit/b32c83ee037d325a9fb68d4d1f6bccc0433cf64e
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Reorder switch() cases

This gathers all the similar case statements together


  Commit: 0bbe98e306a40825bd3b4c9cb49a1ea9b58ea22c
      
https://github.com/Perl/perl5/commit/0bbe98e306a40825bd3b4c9cb49a1ea9b58ea22c
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Add in some early checking for octals

When we get a leading 0 that isn't hex or binary, we already check if
the next character is an 'o', which is a newer syntax for indicating
octals.  We can rule out other things at the same time from being octal.
For example 0.0 isn't octal, nor 0e1


  Commit: 2d2f5d71e97e010c47014d4258ba7b75b4733837
      
https://github.com/Perl/perl5/commit/2d2f5d71e97e010c47014d4258ba7b75b4733837
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Change variable name

'new_octal' may have made sense when this spelling was new, but it
hasn't been new for a long time.  Use a more descriptive spelling


  Commit: 6006b919dca1cc56af33741fbff41aec926a5836
      
https://github.com/Perl/perl5/commit/6006b919dca1cc56af33741fbff41aec926a5836
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Add number base variable

Instead of just the shift, add a variable giving 2, 8, 10, 16.  This
will be used in future commits.

This allows the removal of a small array.

This also allows us to narrow the scope of 'shift', which is less clear
than 'base'


  Commit: 46525a5867490dfe5b7fdd22e6da60514a790ec2
      
https://github.com/Perl/perl5/commit/46525a5867490dfe5b7fdd22e6da60514a790ec2
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Remove variable no longer needed

With the addition of 'base' in the previous commit, 'hexfp' becomes
redundant.


  Commit: eb632ed358b86b3d851313b219967353856bba51
      
https://github.com/Perl/perl5/commit/eb632ed358b86b3d851313b219967353856bba51
  Author: Karl Williamson <[email protected]>
  Date:   2026-07-20 (Mon, 20 Jul 2026)

  Changed paths:
    M toke.c

  Log Message:
  -----------
  scan_num: Change name of label

The new name more accurately describes what is going on, except for one
case, which will be removed in the next commit.


Compare: https://github.com/Perl/perl5/compare/0afd618e8af6...eb632ed358b8

To unsubscribe from these emails, change your notification settings at 
https://github.com/Perl/perl5/settings/notifications

Reply via email to