Branch: refs/heads/blead
  Home:   https://github.com/Perl/perl5
  Commit: bf3cc76b76c150e706bbc042122b203c28d1db1a
      
https://github.com/Perl/perl5/commit/bf3cc76b76c150e706bbc042122b203c28d1db1a
  Author: Paul "LeoNerd" Evans <[email protected]>
  Date:   2026-07-21 (Tue, 21 Jul 2026)

  Changed paths:
    M dump.c
    M mro_core.c
    M regen/embed.pl
    M sv.h
    M sv_inline.h

  Log Message:
  -----------
  Rename HvAMAGIC to HvOVERLOAD

* Rename the SVf_AMAGIC flag to SVphv_OVERLOAD
* Rename the HvAMAGIC set of macros to HvOVERLOAD
* Provide back-compatibility wrappers for the old name when !PERL_CORE

This flag is only ever used on SVt_PVHV, so it makes sense to name it
accordingly. The added `assert` checks that no other kind of SV is ever
used with this flag, so we can be sure we can reuse the bit for other
kinds of SVs in future if needed.



To unsubscribe from these emails, change your notification settings at 
https://github.com/Perl/perl5/settings/notifications

Reply via email to