On Fri, Oct 10, 2003 at 05:55:11PM -0400, Melvin Smith wrote: > Which ones? The PIOCTL ones are, for a lack of current > interface, a way for interfacing to the lower level IO > system through a catchall opcode. It can be anything from > setting terminal modes, buffering, separator characters, the > list goes on.
Sorry. Wasn't clear. The PIOCTL macros are (to me) the correct way of doing something. -6 and -3 are magic numbers. They have no context as to what they might be. > At 04:46 PM 10/10/2003 +0100, Nicholas Clark wrote: > >On Fri, Oct 10, 2003 at 02:43:10AM -0000, Melvin Smith wrote: > >> + else if(arg == PIOCTL_BLKBUF) { > >> + PIO_setbuf(interpreter, pmc, PIO_UNBOUND); > >> + return 0; > >> + } > >> + else return -3; > > > >> case PIOCTL_CMDGETBUFSIZE: > >> if(b) return b->size; > >> else return -6; > >> > > > >What are all these magic numbers about? > > > >Nicholas Clark > > Nicholas Clark