More on the STM branch:

ANSWERS, FOR A CHANGE

 * A comment asks:

     /* XXX is it okay to combine flatten/slurpy into one flag? */

   The answer is "No": "flat" is an output flag, "slurpy_array" is an input
   flag, and there's no guarantee that the input and output flags won't
   conflict with each other.  So I guess this means that something has to
   change.


 * Another comment asks:

    # autogenerate for exotic types
    # (XXX is this appropriate or do we want them to each
    # be explicitly cleared to have the variant?)

   Well, that depends.  Is there currently any way for a named METHOD to
   specify whether it is :write, and if so, is this used?  If so, then yes,
   making an automatic ro variant is OK.  If not, then I think we might want
   such a thing...?


MORE QUESTIONS

 * The '@' character for native call signatures is new, and AFAICT is just
   syntactic sugar, since the caller could do the array creation himself.
   Could you explain what you would have to do if you didn't introduce this
   feature?  (I'm not necessarily against it, mind you, I just want to know
   what the deal is.)


ANOTHER NAMING THING

 * Please rename 'ro_variant' to something ending in '_vtable',
   e.g. 'ro_variant_vtable', to make clear that it's not a class pointer
   or type number.


-- 
Chip Salzenberg <[EMAIL PROTECTED]>

Reply via email to