On Tue, Aug 29, 2000 at 08:56:16AM -0700, Nathan Wiger wrote:
> Tom Christiansen wrote:
> >
> >     $count = getpwnam("tchrist")/l;
> >     $count = getpwnam("tchrist", LIST);
> >     $count = getpwnam("tchrist")->as_list;
> > 
> > All of those, frankly, suck.  This is much better:
> > 
> >     $count = () = getpwnam("tchrist");
> 
> Hmmm. I agree a general purpose mechanism is good, but in this case we
> already have "scalar" so why not "list"?
> 
>     $count = list getpwnam("tchrist");
> 
> While I agree that /l is bad, I think going through the crap of "= () ="
> is even worse. Does it work? Yes. But is it easily usable and fun, even
> for non-experts? No.

I'll agree that /l is bad too.  But I think adding a new "list"
keyword is also bad.  What about other contexts?  Are we going to have
"scalar", "list", "hash", "boolean", "string", "number", etc.?  Not to
mention (even though I am) user-defined contexts (my Dog $spot; $spot
= gen_dog();  <-- that's a "Dog" context).

-Scott
-- 
Jonathan Scott Duff
[EMAIL PROTECTED]

Reply via email to