>>>>> "PRL" == Perl6 RFC Librarian <[EMAIL PROTECTED]> writes:

  PRL>     -r  freadable()
  PRL>     -w  fwriteable()
  PRL>     -x  fexecable()
  PRL>     -o  fowned()

  PRL>     -R  Freadable()
  PRL>     -W  Fwriteable()
  PRL>     -X  Fexecable()
  PRL>     -O  Fowned()

  PRL>     -e  fexists()
  PRL>     -z  fzero()
  PRL>     -s  fsize()

  PRL>     -f  ffile()
  PRL>     -d  fdir()
  PRL>     -l  flink()
  PRL>     -p  fpipe()
  PRL>     -S  fsocket()
  PRL>     -b  fblock()
  PRL>     -c  fchar()
  PRL>     -t  ftty()

  PRL>     -u  fsetuid()
  PRL>     -g  fsetgid()
  PRL>     -k  fsticky()

  PRL>     -T  ftext()
  PRL>     -B  fbinary()

  PRL>     -M  fage()
  PRL>     -A  faccessed()
  PRL>     -C  fchanged()

this looks decent to me. maybe make the prefix f_ to make it a little
more readable (overriding that word again! :)?

also f/Fexecable() looks very odd. is that your choice or were your right
and left hands fighting again? executable is probably the better term
and who cares about 2 chars more if you are using this.

uri

-- 
Uri Guttman  ---------  [EMAIL PROTECTED]  ----------  http://www.sysarch.com
SYStems ARCHitecture, Software Engineering, Perl, Internet, UNIX Consulting
The Perl Books Page  -----------  http://www.sysarch.com/cgi-bin/perl_books
The Best Search Engine on the Net  ----------  http://www.northernlight.com

Reply via email to