On Tue, Feb 06, 2001 at 08:25:17AM +1100, Damian Conway wrote: > > return ( $stuff, $morestuff, $whatever ) always close F; > > I *really* like that keyword. > > Though I'd prefer to see it as a block suffix: > > sub { > ... > return $yadda_yadda; > } > always { close F } > > > Then you could add it to loops as well, in conjunction with the C<continue>: > > while (1) { > ... # add to $text in complex ways > } > continue { $text .= "\n"; } # separate with newlines > always { $trycount++ } # count attempts (including last) Hmmm. If there's such an "always" block, I'd like to see it on all blocks, including the continue [1]. But then, it becomes hard to figure out to which block the always belongs.... [1] Only half-joking. I find it irritating I can't chain continue {} blocks. [2] [2] I guess this is in the same department as me wanting to 'last' out of an if () {} else {} blocks, or to redo them. Abigail
- Re: assign to magic name-of-function variable instead of &... abigail
- Re: assign to magic name-of-function variable instead of &... David L. Nicol
- Re: assign to magic name-of-function variable instead of &... Glenn Linderman
- Re: assign to magic name-of-function variable instead of &... Damian Conway
- Re: assign to magic name-of-function variable instead... Edward Peschko
- Re: assign to magic name-of-function variable instead... Glenn Linderman
- Re: assign to magic name-of-function variable instead... Johan Vromans
- Re: assign to magic name-of-function variable instead of &... abigail
- Re: assign to magic name-of-function variable instead of &... James Mastros
- Re: assign to magic name-of-function variable instead of &... John Porter
- Re: assign to magic name-of-function variable instead of &... Tony Olekshy
- Re: assign to magic name-of-function variable instead... Glenn Linderman
- Re: assign to magic name-of-function variable instead of &... Bart Lateur
- Re: assign to magic name-of-function variable instead of &... Johan Vromans
- Re: assign to magic name-of-function variable instead... John Porter
- Re: assign to magic name-of-function variable instead... Ariel Scolnicov
- Re: assign to magic name-of-function variable instead of &... John Porter