On Wed, Mar 16, 2005 at 12:09:40PM -0800, Larry Wall wrote: > whereas as a native English speaker would probably expect > > $x = whether($a or $b); > > So I'm thinking we'll just go back to "true", both for that reason, > and because it does syntactically block the naughty meaning of true as > a term (as long as we don't default true() to $_), as Luke reminded us.
But "true()" reads weird, and it does not read like an unary (or list) operator at all to me. As the bikeshedding is still going on, may I suggest "aye()"? It is the same length as "not()", both are adverbs, and is rare enough to not conflict with user-defined subs. Thanks, /Autrijus/
Description: PGP signature