>>>>> "MD" == Matt Diephouse <[EMAIL PROTECTED]> writes:

  MD> Uri Guttman <[EMAIL PROTECTED]> wrote:
  >> >>>>> "LW" == Larry Wall <[EMAIL PROTECTED]> writes:
  LW> oct and hex are arguably misnamed, since most functions are named by
  LW> what they produce, not by what they take as input.  I don't know what
  LW> the replacement should be, though.  Maybe it's not worth fixing.
  >> 
  >> from_oct, from_hex which state what they do? or a more general
  >> from_base( 16, $hex )? and that could be curried into from_hex().

  MD>   0xFF.dec()
  MD>   $num.dec()
  MD>   $num.hex()
  MD>   $num.base($n)

  MD> ?

  MD> I believe that some of these can already be handled by C<.as()>.

  MD> I would like for this to be addressed. This is one item that has
  MD> always confused me about Perl 5.

wrong direction. p5's hex and oct parse strings into numbers. .as
converts numbers to string format. larry's point was that the p5 names
were misleading as they didn't return what their names implied they
did. my suggestions were to add 'from' to make that conversion explicit.

uri

-- 
Uri Guttman  ------  [EMAIL PROTECTED]  -------- http://www.stemsystems.com
--Perl Consulting, Stem Development, Systems Architecture, Design and Coding-
Search or Offer Perl Jobs  ----------------------------  http://jobs.perl.org

Reply via email to