On 8/9/05, Larry Wall <[EMAIL PROTECTED]> wrote:
> So why not just use "describes"? Then maybe Object.isa(Foo) delegates
> to $obj.meta.describes(Foo).
Hmm. We have a similar problem with the new class-set notation.
These two things:
Mean two different things:
$a (e) Foo; # or whatever we decide for `elem`
Bar (<=) Foo;
"does" is a nice dwimmy name--it works linguistically for both of
those concepts--but it would be nice to have two names that are
unambiguous for the two cases that "does" delegates to.
Of course, we could use "element" and "subset", but that doesn't work
well for people who don't like to think of types in terms of sets.
Infinite sets aren't exactly beginner-friendly.
Any ideas? I've never been very good at coming up with good names.